Bug 234069 - ia64: validate mmap attributes (WB, UC, etc)
ia64: validate mmap attributes (WB, UC, etc)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-03-26 16:55 EDT by Bjorn Helgaas
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 14:01:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport ioremap_page_range() (3.47 KB, patch)
2007-04-04 11:27 EDT, Bjorn Helgaas
no flags Details | Diff
use same variable names as i386 (2.42 KB, patch)
2007-04-04 11:28 EDT, Bjorn Helgaas
no flags Details | Diff
use ioremap_page_range() to avoid unsupported attributes (4.72 KB, patch)
2007-04-04 11:29 EDT, Bjorn Helgaas
no flags Details | Diff
allow WB mmap of legacy_mem (for option ROMs) (917 bytes, patch)
2007-04-04 11:29 EDT, Bjorn Helgaas
no flags Details | Diff
fail mmaps that span incompatible attributes (2.59 KB, patch)
2007-04-04 11:30 EDT, Bjorn Helgaas
no flags Details | Diff

  None (edit)
Description Bjorn Helgaas 2007-03-26 16:55:07 EDT
ia64 kernel doesn't validate memory attributes (WB, UC, etc) correctly
for mmap of /dev/mem, /sys/.../legacy_mem, and reading /sys/.../rom.

Please incorporate the patches here:

https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=115881
Comment 1 Dave Jones 2007-04-04 00:37:44 EDT
please attach them directly to bugzilla. (Or better yet, get them upstream
before .21?)
Comment 2 Bjorn Helgaas 2007-04-04 11:27:20 EDT
Created attachment 151665 [details]
backport ioremap_page_range()

Tony put these changes in his test tree,so they will go upstream
shortly after 2.6.21.

Apply these in this order:

  ioremap
  ia64-ioremap-align
  ia64-ioremap
  ia64-legacy_mem-wb
  ia64-mmap-validation
Comment 3 Bjorn Helgaas 2007-04-04 11:28:08 EDT
Created attachment 151666 [details]
use same variable names as i386
Comment 4 Bjorn Helgaas 2007-04-04 11:29:05 EDT
Created attachment 151667 [details]
use ioremap_page_range() to avoid unsupported attributes
Comment 5 Bjorn Helgaas 2007-04-04 11:29:39 EDT
Created attachment 151668 [details]
allow WB mmap of legacy_mem (for option ROMs)
Comment 6 Bjorn Helgaas 2007-04-04 11:30:13 EDT
Created attachment 151669 [details]
fail mmaps that span incompatible attributes
Comment 7 Dave Jones 2007-04-04 17:05:14 EDT
Doesn't apply to Linus' latest tree.

+ echo 'Patch #400 (linux-2.6-backport-ioremap-page-range.patch):'
Patch #400 (linux-2.6-backport-ioremap-page-range.patch):
+ patch -p1 -s
1 out of 1 hunk FAILED -- saving rejects to file include/linux/io.h.rej
The next patch would create the file lib/ioremap.c,
which already exists!  Assume -R? [n] 


Looks like these are 2.6.18 patches?
Comment 8 Bjorn Helgaas 2007-04-04 18:50:14 EDT
These are against RHEL5.  What base would you like?
Comment 9 Prarit Bhargava 2007-04-04 19:05:59 EDT
(In reply to comment #8)
> These are against RHEL5.  What base would you like?

Seeing how this is a Fedora bug -- Fedora or upstream :)

P.

Comment 10 Dave Jones 2007-04-04 20:08:32 EDT
Fedora constantly tracks upstream. Right now, it's at 2.6.21rc5-git12 for example.
Comment 11 Bjorn Helgaas 2007-04-10 14:53:14 EDT
OK.  If Fedora tracks upstream closely, I don't think there's any
rush.  I'm happy to wait until Tony pushes them upstream and Fedora
updates to an upstream release that includes them.

I was under the mistaken impression that Fedora would be basically
a RHEL5 kernel with some new patches that might be candidates for
future RHEL5 updates.

If you want to close this as WONTFIX or DEFERRED or whatever, that's
fine with me.  Sorry for the distraction.

Note You need to log in before you can comment on or make changes to this bug.