Bug 23407 - iptables does not include ip6tables
Summary: iptables does not include ip6tables
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-05 12:30 UTC by Arthur van Leeuwen
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-13 23:29:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arthur van Leeuwen 2001-01-05 12:30:37 UTC
The iptables 1.1.1-2 RPM does not include the ip6tables commandline tool,
thereby making it impossible to configure IPv6 filtering. This has not been
fixed in 7.1b1 either, as it includes iptables 1.1.1-2 as well.

Comment 1 Bernhard Rosenkraenzer 2001-01-06 13:54:38 UTC
Not a bug, since we aren't supporting IPv6 at this time.
I've fixed this in the current version (1.1.2-1) nevertheless.

Comment 2 Pekka Savola 2001-01-11 21:52:15 UTC
You should ship ipv6 versions in -ipv6 subpackages.


Comment 3 Bernhard Rosenkraenzer 2001-01-11 22:03:42 UTC
I actually did this in iptables. ;)

Comment 4 Pekka Savola 2001-01-13 23:29:44 UTC
It seems iptables includes the following:

/usr/lib/iptables/libip6t_icmp.so
/usr/lib/iptables/libip6t_standard.so
/usr/lib/iptables/libip6t_tcp.so
/usr/lib/iptables/libip6t_udp.so

Shouldn't these be in iptables-ipv6?  

A very minor issue though.


Comment 5 Bernhard Rosenkraenzer 2001-01-15 13:18:47 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.