Bug 234127 - glchess 3d mode doesn't work + fix
glchess 3d mode doesn't work + fix
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On: Merge
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-27 05:14 EDT by Hans de Goede
Modified: 2013-01-09 23:13 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.18.2.1-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 12:50:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-03-27 05:14:09 EDT
Starting glchess gives the following message:

"Your system does not have the required software to enable 3D mode. Please
contact your system administrator and ask them to install the OpenGL Python
bindings and the GtkGLExt Python bindings.

You are still able to play chess in 2D without these packages."

Notice I had glchess on my machine as a seperate program prior to this,
you may need to goto the view menu and check the 3D box to get this message.

I've packaged up both PythonGL: review bug 234121 (license issues cleared with
Spot) and pygtkglext: review bug 234122 . I'm sure I can have/get this reviewed
within 2 days.

All that is needed then of gnome-games is to add a "Requires: pygtkglext" (which
will bring in PyOpenGL itself).

The only possible problem with this is the additional size of these packages for
the livecd. They aren't big, but still:
-rw-rw-r-- 1 hans hans 136939 2007-03-27 10:28 pygtkglext-1.1.0-1.fc7.x86_64.rpm
-rw-rw-r-- 1 hans hans 1218835 2007-03-26 22:51 PyOpenGL-3.0.0-0.1.a6.fc7.noarch.rpm

Also PyOpenGL needs (runtime!) python-setuptools, which AFAIK is new for another:
-rw-r--r-- 1 root root 486533 2007-03-25 18:03
python-setuptools-0.6c5-1.fc7.noarch.rpm

So in total thats a little under 2 Mb which is additionally needed. I've added
JK to the CC, to hear what he thinks about this both from a releng and a live
CD-disk space POV.

If this is elligble for Fedora 7 inclusion please let me know and then I'll make
sure those packages get reviewed ASAP.


p.s.

I started working on this because I wanted to package op glchess, as I didn't
know it had become a part of gnome-games. I would still like to add glchess to
FE for FC-6, so I think it would be a good idea to add:
Obsoletes: glchess < 2
To gnome-games, regardless the outcome of the rest of this bug.
Comment 1 Jesse Keating 2007-03-27 07:43:37 EDT
We should wait for the merger (just a short time off) before having a Core
package Require an Extras package.

As for LiveCD.... we're very very very tight on space as it is, having to remove
documentation to fit.  Not a very good place to be.  LiveCD is always going to
be losing functionality as our software gets bigger, CD's do not.  However with
the tools to create such things available, it should be easy to create say a
Fedora Games LiveCD that has just enough desktop to run the games that will fit
on the rest of the media.
Comment 2 Hans de Goede 2007-03-27 07:48:11 EDT
(In reply to comment #1)
> We should wait for the merger (just a short time off) before having a Core
> package Require an Extras package.
> 
Is this doable before Fedora 7?

> As for LiveCD.... we're very very very tight on space as it is, having to remove
> documentation to fit.  Not a very good place to be.  LiveCD is always going to
> be losing functionality as our software gets bigger, CD's do not.

I understand, but for a normal / DVD install to get a proper glchess in
gnome-games, gnome-games should have a "Requires: pygtkglext", which indirectly
will make gnome-games bigger by about 2 Mb, is gnome-games on the livecd?

Maybe its an idea (post Fedora 7) to split gnome-games up a bit in say
gnome-games-minimal + gnome-games-extras, so that we can have a smaller most
popular games only gnome-games for the live CD?

Comment 3 Jesse Keating 2007-03-27 08:58:55 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > We should wait for the merger (just a short time off) before having a Core
> > package Require an Extras package.
> > 
> Is this doable before Fedora 7?

yes.  We're targetting shortly after test3 goes out.

> > As for LiveCD.... we're very very very tight on space as it is, having to remove
> > documentation to fit.  Not a very good place to be.  LiveCD is always going to
> > be losing functionality as our software gets bigger, CD's do not.
> 
> I understand, but for a normal / DVD install to get a proper glchess in
> gnome-games, gnome-games should have a "Requires: pygtkglext", which indirectly
> will make gnome-games bigger by about 2 Mb, is gnome-games on the livecd?

It is, and thus a concern.  There may be ways to exclude some stuff, but given
that gnome-games is monolithic it is hard to segregate the requirements into
each game.

> Maybe its an idea (post Fedora 7) to split gnome-games up a bit in say
> gnome-games-minimal + gnome-games-extras, so that we can have a smaller most
> popular games only gnome-games for the live CD?
> 
> 

That just moves the problem to the -extras package.
Comment 4 Hans de Goede 2007-03-27 09:01:49 EDT
(In reply to comment #3)
> > Maybe its an idea (post Fedora 7) to split gnome-games up a bit in say
> > gnome-games-minimal + gnome-games-extras, so that we can have a smaller most
> > popular games only gnome-games for the live CD?
> > 
> > 
> 
> That just moves the problem to the -extras package.
> 

Yes, but then we could put only the gnome-games-minimal package on the live-cd,
thus actually freeing space up, instead of taking extras space, maybe its even
an idea todo this prior to Fedora 7? A simple split should be doable without
introducing bugs (I know any change introduces bugs).
Comment 5 Ray Strode [halfline] 2007-03-27 10:58:15 EDT
I'm not opposed to doing the split up or adding the requires, but probably for
F8 because we're already in feature freeze.
Comment 6 Hans de Goede 2007-03-27 11:00:38 EDT
(In reply to comment #5)
> I'm not opposed to doing the split up or adding the requires, but probably for
> F8 because we're already in feature freeze.

Understandable, but also regrettable, that means that we will have a crippled
glchess for the whole of Fedora 7, Maybe the requires can be added if we have
the space on the livecd and/or with the first Fedora 7 gnome-games update?
Comment 7 Ray Strode [halfline] 2007-03-27 15:14:26 EDT
yea we might be able to get it out as an update post GA, as long as it gets a
solid amount of time in updates-testing first.
Comment 8 Hans de Goede 2007-04-05 13:07:29 EDT
Notice to those who want to test the 3D mode, PyOpenGL and pygtkglext are now
available in FE, so on Fesora 7 with a "yum install pygtkglext" you will get 3D
support in glchess.

Ray,

glchess is currently under review for inclusion into FC-6 as a stand alone
package, can you please add an "Obsoletes glchess < 2.0" line to the
gnome-games.spec so that people installing this and later upgrading to Fedora 7
have a smooth upgradeboth, AFAIK there is no way to accomplish the same thing
from the glchess package.
Comment 9 Ray Strode [halfline] 2007-04-08 14:51:51 EDT
Sure, I can do that when we do the split up.
Comment 10 Hans de Goede 2007-04-08 14:56:18 EDT
(In reply to comment #9)
> Sure, I can do that when we do the split up.

Erm, would that be pre test4? IOW, would that make Fedora 7 the CD / DVD, I
would like to avoid this scenario:
1) user with FC-6 installs glchess
2) somewhat later user decides to update to Fedora 7, the official way, pops in
   CD / DVD and selects upgrade.
3) yum explodes because the glchess files from gnome-games in Fedora 7 conflict 
   with those from the stand alone version in FC-6
Comment 11 Ray Strode [halfline] 2007-04-08 15:14:04 EDT
Oh, right.  I'm sorry, I'll add the conflicts / provides right now.
Comment 12 Bill Nottingham 2007-05-24 01:05:40 EDT
Did this get done?
Comment 13 Hans de Goede 2007-07-04 05:12:56 EDT
Ping, any progress on this? Fixing it is as easy as adding:
Requires: pygtkglext PyOpenGL

To the spec.
Comment 14 Ray Strode [halfline] 2007-07-05 12:05:58 EDT
I've added the Requires to F-7 and rawhide now.  I'll put an update in
-updates-testing when it gets done building.

I've also added jwrdegoede to the pkg.acl file for gnome-games, so you won't
have to block on me anymore for changes like this when I'm slow.

marking MODIFIED until the update goes out.
Comment 15 Hans de Goede 2007-07-05 12:17:18 EDT
(In reply to comment #14)
> I've also added jwrdegoede to the pkg.acl file for gnome-games, so you won't
> have to block on me anymore for changes like this when I'm slow.
> 

Thanks for the confidence in me! How do we coordinate / avoid CVS commit
conflicts? As in my experience the chance for colissions is small, I guess that
the best way is to just not coordinate most of the time, and only drop the other
party a mail when doing big changes, agreed?

And what about building new versions, do you want to review changes I make
before I request a build, or may I build when I've fixed a couple of bugs and
think the new version is ready for rawhide? In the Fedora 7 (released version)
case I think that it actually is a good idea for you to look over my changes
before building and pushing to updates-testing.
Comment 16 Ray Strode [halfline] 2007-07-05 12:31:49 EDT
I'd say let's not worry about coordinating too much.  In the case of a cvs
conflict, the person who sees the conflict should look at what changes went in,
and figure out how it affects things (and do merging or whatever).

Just make sure any fixes you commit get filed upstream, too.  Feel free to shoot
me a mail if you want me to look at a change you're doing.
Comment 17 Fedora Update System 2007-07-06 08:35:25 EDT
gnome-games-2.18.2.1-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Hans de Goede 2007-08-08 04:11:12 EDT
Ray, gnome-games has been in updates-testing for a while now, maybe now is a
good moment to push it to updates-stable?
Comment 19 Fedora Update System 2007-08-09 12:50:13 EDT
gnome-games-2.18.2.1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Tim 2007-08-10 02:47:03 EDT
The gnome-games-2.18.2.1-3.fc7 update listed a devel package as a dependency.

When updating gnome-games, and only gnome-games, it installed for dependencies: 
python-devel-2.5-12.fc7, PyOpenGL-3.0.0-0.3,.a6.fc7 pygtkglext-1.1.0-2.fc7, & 
python-setuptools-0.6c6-1.fc7.

I don't think ordinary things should require devel packages.  We shouldn't need 
them unless we're going to work on developing something.  Out of 1136 packages, 
this is the only devel package installed on my system.
Comment 21 Hans de Goede 2007-08-10 04:55:50 EDT
Ah, PyOpenGL requires python-setuptools (which it _really_ needs) which in turn
requires python-devel. python-setuptools shoul be split into a runtime needed
parts and a -devel, bug filed: bug 251645.

Note You need to log in before you can comment on or make changes to this bug.