Bug 234133 - Kernel panic caused by failure in initrd after standard installation
Summary: Kernel panic caused by failure in initrd after standard installation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: ia64 Linux
medium
urgent
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 10:51 UTC by Robert Scheck
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 20:01:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot from kernel panic (675.80 KB, image/jpeg)
2007-03-27 10:58 UTC, Robert Scheck
no flags Details
"lspci -vvv" output (using RHEL4 on the same machine) (23.33 KB, text/plain)
2007-03-28 19:21 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2007-03-27 10:51:11 UTC
Description of problem:
After a normal installation including software RAID of Red Hat Enterprise
Linux 5 (Server) at a HP rx2600 Itanium 2 server, the boot process ends with 
the screenshot attached below.

RAID DEVICES
  /dev/md0 ext3 15202.1MB
    (one disk as hotspare)

Hard Drives
  /dev/sda
    /dev/sda1 vfat 102MB (boot)
    /dev/sda2 Software Raid 15202MB
    /dev/sda3 swap 1992MB
    Free 63MB
  /dev/sdb
    /dev/sdb2 Software Raid 15202MB
    /dev/sdb1 swap 2157MB
  /dev/sdc
    /dev/sdc2 Software Raid 15202MB
    /dev/sdc1 swap 2157MB

Version-Release number of selected component (if applicable):
Standards from Red Hat Enterprise Linux 5 release.

How reproducible:
Everytime on a HP rx2600 Itanium 2 server.

Actual results:
Non-bootable system after standard installation.

Expected results:
Bootable system after standard installation...

Comment 1 Robert Scheck 2007-03-27 10:58:15 UTC
Created attachment 151011 [details]
Screenshot from kernel panic

Comment 2 Luming Yu 2007-03-28 08:56:27 UTC
Sounds like something is missing from the initrd image.
what does the initrd image looks like?


Comment 3 Robert Scheck 2007-03-28 19:21:00 UTC
Unfortunately I'm only the man-in-the-middle (ex-colleague with the server
and myself with some knowledge and the interest to solves this problem, as HP 
rx2600 Itanium 2 servers are common machines).

For now, I can provide you a "lspci -vvv" output from RHEL4 on the same 
machine, because the box is a project machine and should work (which does 
currently only with RHEL4). If there are any information, I'm able to obtain
when having RHEL4, let me know. I don't know, when there's time and the
possibility to re-install RHEL5 for another try and further information. And
please let me know, what is needed exactly for further debugging purposes.

Comment 4 Robert Scheck 2007-03-28 19:21:46 UTC
Created attachment 151150 [details]
"lspci -vvv" output (using RHEL4 on the same machine)

Comment 6 RHEL Product and Program Management 2007-05-01 15:53:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Robert Scheck 2007-05-01 17:00:11 UTC
Hum? Did I miss something? Where is the real fix for this problem?

Comment 8 Peter Jones 2007-05-02 19:16:55 UTC
Can you boot again without the "quiet" option and show the output from *that*,
so we'll have more than just the error messages?

Comment 9 Robert Scheck 2007-05-15 20:32:04 UTC
Well, nice that you're willing to help nearly two months later when the machine 
went to production use with RHEL4 :( But I'll see whether I can get another box 
having this problem, too.

Comment 11 RHEL Product and Program Management 2007-06-04 20:01:35 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 


Note You need to log in before you can comment on or make changes to this bug.