Bug 234143 - g{cc,++}32 fails to find libg2c
g{cc,++}32 fails to find libg2c
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: compat-gcc-32 (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-27 10:03 EDT by Kostas Georgiou
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 10:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kostas Georgiou 2007-03-27 10:03:44 EDT
gcc32 -o foo ... -lg2c fails since compat-gcc-32 doesn't provide libg2c.so

I am not sure what is the best solution here (sadly forcing the users to get
their act together and moving to something recent isn't an option), providing
compat-g77-32 with the full(?) g77 stack is one option and the other is to use
the existing /usr/lib/libg2c.so.0 assuming libg2c hasn't changed at all.

The users are only interested in linking from gcc-32 with libg2c and not a
g77-32 so compat-libf2c is probably an option.
Comment 1 Jakub Jelinek 2007-03-27 10:55:28 EDT
So compile C code with gcc32, Fortran code with g77 and link using
gcc or g77 rather than gcc32.
Adding g77 compatibility stuff is an overkill.

Note You need to log in before you can comment on or make changes to this bug.