This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 23423 - Factory installation fails on IDE drives.
Factory installation fails on IDE drives.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 11:22 EST by Rogelio Noriega
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 16:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rogelio Noriega 2001-01-05 11:22:45 EST
Factory installation fails on IDE drives.  Fdisk shows that an IDE drive 
that
that had this geometry on RH Linux 7.0

/dev/hda: 255 heads, 63 sectors, 2432 cylinders

has this geometry on Florence beta1

/dev/hda: 16 heads, 63 sectors, 38760 cylinders

We have a 3 GB Win95 partition that we use for our factory installation.
With a geometry of 16 heads the Win95 partions ends on cylinder 6248.
This is beyond the 1023 limit and kickstart blows up.  fdisk also has the
following error:

partition 1 does not end on cylinder boundry:
phys = (391,254,63) should be (391,15,63)

which indicates that the system is confused about the disk geometry.

This is a show stopper for factory installation for systems with IDE 
drives.
Comment 1 Michael Fulbright 2001-01-09 16:43:51 EST
The kernel is reporting a different geometry in 2.4 than 2.2.

Assigning to kernel component.
Comment 2 Rogelio Noriega 2001-01-11 09:16:35 EST
Florence Beta 2

Test system: Precision 330 w/ Pentium 4 step 7, 768 RAM, 40 GB IDE Drive

Drive geometry as reported on HDD label: 16386 C/16 H/ 63 S.

Test procedure:

Make a Win95 2.5 GB partition with Win95 fdisk.
Make the partition active and format it.

This works:
Boot from RH 7 CDROM
Type: linux rescue
Type: mknod /dev/hda
Type: fdisk /dev/hda
Type: p

Fdisk reports:

Disk /dev/hda: 255 heads, 63 sectors, 4982 cyclinders
/dev/hda1	*	1	319	256233	b	Win85 FAT32

This doesn't work:
Boot from Florence Beta2 CDROM
Type: linux rescue
Type: mknod /dev/hda
Type: fdisk /dev/hda
Type: p

Fdisk reports:

Disk /dev/hda: 16 heads, 63 sectors, 79406 cyclinders (note that this is the 
incorrect number of  heads and cylinders)
/dev/hda1	*	1	5085	256233	b	Win85 FAT32 (wrong 
number of cylinders)
Partition 1 does not end on cylinder boundry
phys (318,254,63) should be(318,15,63)

There are several problems with this:  The cylinder count is very wrong - it is 
more than physically possible.
	The preferred geometry is 255,63,4982 as reported by RH 7.

The result is that we can't install Florence Beta2 if there is an existing 
WIN95 pertition.
Comment 3 Glen Foster 2001-01-11 16:05:20 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Michael K. Johnson 2001-01-12 14:54:51 EST
This is almost certainly due to our attempt to support modular IDE.
Modular IDE has, among other things, problems dealing with geometry.
We have reverted to static IDE for the future.

If the next beta doesn't fix this, please re-open this bug report.
Comment 5 Dan Taylor 2001-01-30 12:13:36 EST
Confirmed fixed in beta3/fisher

Note You need to log in before you can comment on or make changes to this bug.