Bug 23424 - up2date 2.1.7-0.6.x fails when run through ssh
up2date 2.1.7-0.6.x fails when run through ssh
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 11:35 EST by phostetl
Modified: 2015-01-07 18:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 20:34:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description phostetl 2001-01-05 11:35:32 EST
When connecting via ssh from a Red Hat 7.0 or 6.2 system to any Red Hat 6.2
system running the current up2date the following error occurs:

[root@redhat6box /root]# /usr/bin/up2date         
Gdk-ERROR **: X connection to redhat6box:10.0 broken (explicit kill or
server shutdown).

[root@redhat6box /root]# rpm -qa | grep up2date
up2date-2.1.7-0.6.x
up2date-gnome-2.1.7-0.6.x

Other apps xlogo, xeyes... seem to run and display properly.  

Up2date (up2date-2.1.7-1) on a Red Hat 7.0 box works fine over ssh.
Comment 1 Need Real Name 2001-02-05 14:48:28 EST
I am connected via SSH and am getting totally different errors.

I am running RH7 headless and w/o x installed so I have to run up2date
from the command line.  I haven't seen anything that says you can't.  In
fact,
http://www.redhat.com/support/manuals/RHNetwork/ref-guide/text-up2date.html
says that you can.  This is the first use of up2date.  I have manually
imported the key and still have no success at all.  I have a virtually
identical set up on my workstation with the exception that x is
installed.  This works perfectly.  I don't understand what the problem
is and am hoping that some of you have some insight.

I am attempting to use up2date from the command line as follows

# up2date -r -l

which times out.  When I try

#up2date --nosig -l I get:

Traceback (innermost last):
  File "/usr/sbin/up2date", line 382, in ?
    main()
  File "/usr/sbin/up2date", line 366, in main
    sys.exit(batchRun(onlyList, pkgNames))
  File "/usr/sbin/up2date", line 138, in batchRun
    updated, skipped = up2date.getUpdatedPackageList(printit, percent)
  File "/usr/share/rhn/up2date/up2date.py", line 872, in
getUpdatedPackageList
    pkgList = getAvailablePackageList()
  File "/usr/share/rhn/up2date/up2date.py", line 267, in
getAvailablePackageList
    availPkgList = s.up2date.listall(getSystemId())
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 576, in
__call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 602, in
__request
    request = dumps(params, methodname)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 470, in
dumps
    data = m.dumps(params)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 246, in
dumps
    self.__dump(v)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 257, in
__dump
    raise TypeError, "cannot marshal %s objects" % type(value)
TypeError: cannot marshal <type 'None'> objects



Comment 2 Preston Brown 2001-02-08 22:51:09 EST
what usermode do you have on your 6.2 box?
Comment 3 phostetl 2001-02-09 13:00:44 EST
usermode-1.37-1.6
Comment 4 Cristian Gafton 2001-02-19 20:34:33 EST
Assigned QA to jturner
Comment 5 Preston Brown 2001-02-26 18:51:47 EST
I can't duplicate the 7.0 / 6.2 ssh interaction problem; it works here.  Very
strange.  It even pops up the usermode authentication dialog on the remote box
properly.

The 2nd problem appears to have been a transient server side problem that has
been since corrected.
Comment 6 R P Herrold 2001-03-03 06:26:56 EST
This is probably a DNS/rDNS issue ... openssh is quite strict about opening
tunnels -- debugging technique would be to modify nsswitch.conf order DNS
support order, and induce a failure

Note You need to log in before you can comment on or make changes to this bug.