Bug 234342 - Evolution process explodes while composing email
Evolution process explodes while composing email
Status: CLOSED DUPLICATE of bug 247745
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-28 12:25 EDT by Christopher Beland
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 05:07:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of gdb backtrace and step-through (5.50 KB, text/plain)
2007-09-10 15:54 EDT, Christopher Beland
no flags Details

  None (edit)
Description Christopher Beland 2007-03-28 12:25:04 EDT
Description of problem:
While composing an e-mail message, Evolution suddenly stops accepting keyboard
input.  The Evolution process starts expanding, taking up increasingly large
amounts of memory until it is killed or the system is rebooted.  At best, it is
caught early but forces other processes to be swapped out, making system
performance thereafter very slow until the applications being used are swapped
back in.  At worst, a system restart is forced, potentially losing whatever
information was actively being worked on in other applications.

Version-Release number of selected component (if applicable):
gtkhtml3-3.12.3-1.fc6
evolution-2.8.3-1.fc6

How reproducible:
Seems to happen once every one or two weeks.  Does not happen every time an
e-mail is composed, and there is no obvious pattern as to when in the
composition process.  (It's not always on the first line, it's not always very
long messages, etc.)
Comment 1 Christopher Beland 2007-09-10 15:54:25 EDT
Created attachment 191971 [details]
Results of gdb backtrace and step-through

This was originally reported in Fedora 6, but is still a problem in Fedora 7
with evolution-2.10.3-4.fc7 and gtkhtml3-3.14.3-1.fc7.

This time I did manage to attach gdb to the process before it completely
overwhelmed the system.  Results from a backtrace and attempted step-through
are attached.  If there's anything in particular I can do that would be more
helpful the next time this happens, let me know.
Comment 2 Christopher Beland 2007-09-11 21:48:14 EDT
It sounds like Bug 247745 has the same symptom.
Comment 3 Milan Crha 2007-11-21 05:07:56 EST
You've right, Christopher, you've same stack trace as at the second bug. I will
mark this bug as duplicate, because the second one contains more detailed stack
trace. Also, as is mentioned there, at the next other bug is a patch, which has
been moved upstream to fix this. Thanks for your help.

*** This bug has been marked as a duplicate of 247745 ***

Note You need to log in before you can comment on or make changes to this bug.