Bug 23437 - GCC segfaulted when compiling apache 1.3.14 from source.
Summary: GCC segfaulted when compiling apache 1.3.14 from source.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-05 19:32 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 13:55:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-01-05 19:32:42 UTC
using the apache_1.3.14.tar.gz tarball,  atempting to compile the code 
with gcc 2.96, I did this:
./configure --prefix=/usr/local/apache --enable-shared=ssl
configure completed sucessfully
make gave me this:
gcc -c  -I../../os/unix -I../../include   -DLINUX=2 -DUSE_HSREGEX -
DUSE_EXPAT -I../../lib/expat-lite `../../apaci` mod_negotiation.c
mod_negotiation.c: In function `get_entry':
mod_negotiation.c:406: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[4]: *** [mod_negotiation.o] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/tmp/apache_1.3.14/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/tmp/apache_1.3.14'
make: *** [build] Error 2

Below is the 
gdb apprunner core 
# gdb apprunner core 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you 
are
welcome to change it and/or distribute copies of it under certain 
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...apprunner: No such file 
or directory.

Core was generated by `sh ./configure --prefix=/usr/local/apache --enable-
shared=ssl'.
%0

Comment 1 Jakub Jelinek 2001-01-07 10:50:44 UTC
Can you please rerun
gcc -c  -I../../os/unix -I../../include   -DLINUX=2 -DUSE_HSREGEX -
DUSE_EXPAT -I../../lib/expat-lite `../../apaci` mod_negotiation.c -save-temps -v
and attach here mod_negotiation.i this command produces? Thanks.

Comment 2 Karsten Hopp 2001-02-19 13:55:53 UTC
Could not reproduce this with apache_1.3.14.tar.gz, mod_ssl-2.7.1-1.3.14.tar.gz
and gcc-2.96-75. Seems to be fixed.

Comment 3 Karsten Hopp 2001-03-07 22:46:11 UTC
Please reopen this bug if our current gcc doesn't fix this.
As I wrote before, I couldn't reproduce it with gcc-2.96-75


Note You need to log in before you can comment on or make changes to this bug.