Bug 234382 - intelfb cannot be used for local flat panel (laptop)
intelfb cannot be used for local flat panel (laptop)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-03-28 15:57 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2009-12-18 00:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 00:54:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-03-28 15:57:45 EDT
Description of problem:
I'd like to use intelfb instead of vesafb for a big console.
After adding MODULES=intelfb to /etc/sysconfig/mkinitrd as suggested on
#fedora-devel and rebuilding the initrd I thought it would just work.
It didn't. I tried adding video=intelfb:mode=1280x800 no change.
Kernel output:

[...]
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sda: sda1 sda2 < sda5 sda6 sda7 >
sd 0:0:0:0: Attached scsi disk sda
intelfb: Framebuffer driver for Intel(R)
830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM chipsets
intelfb: Version 0.9.4
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
intelfb: 00:02.0: Intel(R) 945GM, aperture size 256MB, stolen memory 7932kB
intelfb: Non-CRT device is enabled ( LVDS port ).  Disabling mode switching.
intelfb: Video mode must be programmed at boot time.
kjournald starting.  Commit interval 5 seconds
[...]

My guess is that unless it's compiled-in, the proper mode won't get initialized.

Version-Release number of selected component (if applicable):
2.6.20-1.2933.fc6

How reproducible:
Always.

Steps to Reproduce:
1. echo MODULES=intelfb >> /etc/sysconfig/mkinitrd
2. mkinitrd /boot/initrd.new `uname -r`
3. edit /etc/grub.conf to use the new initrd
4. reboot

Actual results:
Console stays in 80x25 mode.

Expected results:
Console should switch to framebuffer mode.

Additional info:
vesafb works just fine if I just specify vga=0x360
Comment 1 Chuck Ebbert 2007-03-28 16:16:14 EDT
Try loading intelfb after booting with vga=0x360
Comment 2 Dominik 'Rathann' Mierzejewski 2007-03-28 18:11:42 EDT
Tried:

intelfb: Cannot reserve FB region
Comment 3 Jon Stanley 2008-01-07 20:53:25 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 4 Dominik 'Rathann' Mierzejewski 2008-01-08 11:46:50 EST
It still happens with Fedora 7 (one of the latest kernels). I haven't upgraded
to 8 on that laptop yet.
Comment 5 Dominik 'Rathann' Mierzejewski 2008-01-17 06:06:41 EST
Upgraded to F-8, still no change with 2.6.23.13-105.fc8.
Comment 6 Dominik 'Rathann' Mierzejewski 2008-11-03 15:03:20 EST
Installed F-10snap2 on another laptop, same behaviour.
Comment 7 Bug Zapper 2008-11-25 20:53:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-11-18 07:19:02 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-12-18 00:54:59 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.