Bug 234434 - Broken multi-lib dependency in FC6 update
Broken multi-lib dependency in FC6 update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-29 03:09 EDT by Michael Schwendt
Modified: 2013-01-09 23:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-03-29 03:09:08 EDT
source rpm: poppler-0.5.4-5.fc6.src.rpm
package: poppler-devel - 0.5.4-5.fc6.i386 from fedora-core-updates-6-x86_64
  unresolved deps: 
     libpoppler-qt.so.1

poppler-qt.i386 is not available for x86_64.
Comment 1 Jonathan Underwood 2007-05-05 08:46:41 EDT
Yup:

yum install poppler-devel
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package poppler-devel.x86_64 0:0.5.4-5.fc6 set to be updated
---> Package poppler-devel.i386 0:0.5.4-5.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libpoppler-qt.so.1 for package: poppler-devel
--> Processing Dependency: libpoppler-glib.so.1 for package: poppler-devel
--> Processing Dependency: libpoppler.so.1 for package: poppler-devel
--> Processing Dependency: libpoppler-qt.so.1()(64bit) for package: poppler-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package poppler-qt.x86_64 0:0.5.4-5.fc6 set to be updated
---> Package poppler.i386 0:0.5.4-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: libpoppler-qt.so.1 for package: poppler-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libpoppler-qt.so.1 is needed by package poppler-devel


Please can you fix this for FC6. Not sure if this also affects the F7 packages,
don't have access to a F7T4 machine right now.
Comment 2 Jonathan Underwood 2007-05-15 07:12:47 EDT
Any progress on this? 
Comment 3 Jesse Keating 2007-05-15 11:06:18 EDT
Adding Luke to CC, still need to investigate what needs to be done, been busy
with F7 stuff :(
Comment 4 Bug Zapper 2008-04-04 02:43:17 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 15:26:23 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.