Bug 23445 - /usr/bin/gnome-font-install inf-loops in rawhide 20010103?
/usr/bin/gnome-font-install inf-loops in rawhide 20010103?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-print (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 16:55 EST by dunwoody
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-05 17:51:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dunwoody 2001-01-05 16:55:46 EST
There must be a simple explanation to this problem, but I haven't had time
to investigate.  Perhaps
it is a simple pilot error, and not a bug at all.  Nevertheless, here goes:

My Rawhide 20001222 systems, including  gnome-print-0.20-8.i386.rpm, have
no problem running
the following command, which is included in the postinstall script of
gnome-print-0.20-8.i386.rpm:

/usr/bin/gnome-font-install --system --scan --no-copy \
        --afm-path=/usr/share/fonts/afms \
        --pfb-path=/usr/share/fonts/pfbs \
	--pfb-assignment=ghostscript,/usr/share/ghostscript/fonts \
	--afm-assignment=ghostscript,/usr/share/ghostscript/fonts \
        --pfb-assignment=ghostscript,/usr/share/fonts/default/Type1 \
	--afm-assignment=ghostscript,/usr/share/fonts/default/Type1 \
        /usr/share/fonts

Running the same program on my Rawhide 20010103 systems, with either
gnome-print-0.25-1.i386.rpm or gnome-print-0.20-8.i386.rpm installed, seems
to yield
an infinite loop, or at least a command execution that soaks the CPU for
longer than I am willing
to wait.

These systems all have 352 RPMs installed, almost all from Rawhide.  If
further details would help,
I'd be happy to provide them.  These systems have no
/usr/share/ghostscript/fonts directories, and
they have 771 files under /usr/share/fonts.
Comment 1 Owen Taylor 2001-07-21 18:25:14 EDT
gnome-print-install was considerably rewritten in gnome-print-0.29,
so I'm guessing this probably is fixed now. gnome-print-0.29-2 should
show up in rawhide sometime soon, and if it still happens with
that, please reopen.

Note You need to log in before you can comment on or make changes to this bug.