Bug 234466 - Nomencl.sty is an old version
Nomencl.sty is an old version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-29 10:32 EDT by James Buckle
Modified: 2013-07-02 19:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 13:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the matching nomencl.ist for the nomencl.sty included in tetex-3.0-44.8.fc8 (2.95 KB, application/octet-stream)
2008-03-17 13:17 EDT, Aleksandar Kanchev
no flags Details

  None (edit)
Description James Buckle 2007-03-29 10:32:31 EDT
Description of problem:

Nomencl.sty is a '00 version. Although it is possible to figure out, most online
reference material pertains to newer versions with \makenomenclature instead of
\makeglossary. Documents created on most windows versions are not
cross-compilable due to the windows versions using latest versions.

Version-Release number of selected component (if applicable):
2000/12/03 v3.1a

I hope this is the right place to note this. Thanks.
Comment 1 Rex Dieter 2007-03-29 10:39:36 EDT
> I hope this is the right place to note this. Thanks.

Prolly not, kile is simply a tex front-end, you're likely more interested in
Core/tetex (re-assigning now).
Comment 2 Rex Dieter 2007-03-29 10:40:18 EDT
reassigned core/tetex
Comment 3 James Buckle 2007-03-29 10:42:22 EDT
Thanks, sorry - youre absolutely right.
Comment 4 Jindrich Novy 2007-04-10 09:57:50 EDT
I updated the nomencl style in rawhide.
Comment 5 Fedora Update System 2007-04-13 15:37:07 EDT
tetex-3.0-34.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 James Buckle 2007-07-04 14:27:45 EDT
I'm not sure about in FC6 but F7 I now get the updated nomencl.sty but the
makeindex style nomencl.ist doesnt match the .sty?
Comment 7 James Buckle 2007-09-10 04:54:35 EDT
Seeing as this apparently isnt going to be fixed heres a workaround,

Edit
/usr/share/texmf/makeindex/nomencl.ist

Change 
keyword    "\\glossaryentry"
to
keyword    "\\nomenclatureentry"

and 
preamble   "\\begin{theglossary} \n"
postamble  "\n\n\\end{theglossary}\n"

to
preamble   "\\begin{thenomenclature} \n"
postamble  "\n\n\\end{thenomenclature}\n"

All should work then.
Comment 8 Roland Wolters 2007-12-02 07:47:31 EST
Thanks for the workaround. Is this bug known upstream?
Comment 9 Jindrich Novy 2007-12-02 07:53:27 EST
tetex upstream doesn't exist, Thomas Esser left the project. We are now moving
to TeXLive.
Comment 10 Aleksandar Kanchev 2008-03-17 13:17:02 EDT
Created attachment 298287 [details]
the matching nomencl.ist for the nomencl.sty included in tetex-3.0-44.8.fc8

I'm using Fedora 8 with tetex-3.0-44.8.fc8
and nomencl.ist is still old.
I'm attaching the new version here. The file
/usr/share/texmf/makeindex/nomencl.ist should be replaced with this one.
Comment 11 Jindrich Novy 2008-03-17 13:47:09 EDT
Exactly this revision of nomencl is used in TeXLive 2007. Please update to
TeXLive to fix it. On F8 please use this repo:

http://people.redhat.com/jnovy/files/texlive/texlive.repo

Note You need to log in before you can comment on or make changes to this bug.