Bug 234485 - LSPP: when searching for larval SAs check the protocol too
LSPP: when searching for larval SAs check the protocol too
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Martin Jenner
: OtherQA
Depends On:
Blocks: RHEL5LSPPCertTracker
  Show dependency treegraph
 
Reported: 2007-03-29 12:21 EDT by Joy Latten
Modified: 2010-10-22 10:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL 5 version of this patch (517 bytes, patch)
2007-03-30 09:36 EDT, Eric Paris
no flags Details | Diff

  None (edit)
Description Joy Latten 2007-03-29 12:21:32 EDT
Description of problem:
Before inserting a new SA into the kernel, a check is made for any
corresponding larval SAs, so they can be removed. A check to ensure
that the policy matches will ensure we are pulling up the correct 
larval SA. 


Additional info:

A patch had been created and included in upstream kernel.
Comment 1 Bryn M. Reeves 2007-03-30 05:58:33 EDT
commit 75e252d981c0e80c14ce90df246e9b1300474c4f
Author: Joy Latten <latten@austin.ibm.com>
Date:   Mon Mar 12 17:14:07 2007 -0700

    [XFRM]: Fix missing protocol comparison of larval SAs.
    
    I noticed that in xfrm_state_add we look for the larval SA in a few
    places without checking for protocol match. So when using both
    AH and ESP, whichever one gets added first, deletes the larval SA.
    It seems AH always gets added first and ESP is always the larval
    SA's protocol since the xfrm->tmpl has it first. Thus causing the
    additional km_query()
    
    Adding the check eliminates accidental double SA creation.
    
    Signed-off-by: Joy Latten <latten@austin.ibm.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=75e252d981c0e80c14ce90df246e9b1300474c4f

This commit depends on a couple of others that don't seem to be in the RHEL5 kernel.
Comment 2 Eric Paris 2007-03-30 09:36:07 EDT
Created attachment 151279 [details]
RHEL 5 version of this patch

Here is a RHEL5 version of this patch.	RHEL5 doesn't implement the
__find_acq_core that is upstream, instead we have seperate functions for xfrm4
and xfrm6.  As it turns out RHEL5 actually checks proto in those 2 fucntion and
the check for proto upstream was dropped when they switched to the unified
__find_acq_core.  So this patch only fixes the other place we forgot to check
proto.	 Has been in the LSPP kernel for weeks and seems to be working fine for
people there.
Comment 3 Joy Latten 2007-03-30 11:56:43 EDT
I ran a 15 hour stress test for labeled ipsec over ipv4 in lspp 70 kernel and
saw no problems.
Comment 4 George C. Wilson 2007-04-02 16:25:11 EDT
Joy has tested this and it is accepted into upstream kernel.
Comment 7 Don Zickus 2007-06-15 20:31:18 EDT
in 2.6.18-27.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 9 John Poelstra 2007-08-27 14:55:56 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 10 Joy Latten 2007-08-28 14:18:54 EDT
Verified that this is fixed.
Comment 12 errata-xmlrpc 2007-11-07 14:45:47 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.