Bug 23457 - Syslog requries newer initscripts for 2.4
Syslog requries newer initscripts for 2.4
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 20:21 EST by Andrew Bartlett
Modified: 2016-11-24 09:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-06 12:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2001-01-05 20:21:40 EST
My machine is a RedHat 7.0 server install, updated with many Rawhide
components (all recompiled).

Under kernel 2.4 (.0-ac1, .0-0.43.11) syslogd (1.3.33-8) stalls during
bootup (but continues eventualy).  This is rectified by installing a newer
initscripts (5.53-1).  Should this be listed as a 'requires' somewhere?  Or
are the newer initscripts masking other behaviour?
Comment 1 Bill Nottingham 2001-01-05 20:26:18 EST
You wouldn't happen to be using NIS, would you?
Comment 2 Andrew Bartlett 2001-01-05 20:48:11 EST
Yep
Comment 3 Andrew Bartlett 2001-01-06 02:14:24 EST
Thanks for the hint:  I looked into my /etc/nsswitch.conf, and found what I had
not expected:

hosts: files nisplus nis dns

so I changed it to what I had expected (and used elsewhere, I use NIS for
sharing password files, I don't need it to do what DNS does better)

hosts: files dns [NOTFOUND=return] nisplus nis

I think this is related to my bug 23459, as previous to this the nisdomainname
was set in rc.sysint, now its set in init.d/ypbind - after syslog starts.

(Is this what you were thinking?)
Comment 4 Andrew Bartlett 2001-01-06 02:18:33 EST
BTW, I don't keep host info in my /etc/hosts file, only:
127.0.0.1 localhost

so thats why syslog does the DNS (and failed NIS) lookup
Comment 5 Bill Nottingham 2001-01-06 12:25:51 EST
OK. The 2.4 kernel has a different behavior on unconnected UDP sockets;
before it would return 'connection refused', which wasn't technically correct.

What happens is that glibc sees that you have a NIS domain name set, so
it tries to talk to portmap; portmap isn't listening, so it sits there
waiting for a response. (with 2.2 it would get the 'connection refused'
error.)

The reason it doesn't hang with the new initscripts is that the new initscripts
don't set the NIS domain name at boot up; they leave it for the ypbind init
script to set.

It's not something that sysklogd really needs to require the new initscripts
for. I'll assign this to glibc, as that's the place the behavior needs to
change (basically, there is some new socket error reporting mechanism
that it can use.)
Comment 6 Jakub Jelinek 2001-01-12 08:09:16 EST
Should be fixed in glibc-2.2-12.

Note You need to log in before you can comment on or make changes to this bug.