Bug 234582 - dhcp time-out when no signal on cable
dhcp time-out when no signal on cable
Status: CLOSED DUPLICATE of bug 234764
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-30 06:04 EDT by Taco Witte
Modified: 2014-03-16 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 14:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taco Witte 2007-03-30 06:04:57 EDT
Description of problem:
After installing a second NIC, DHCP is run on startup when there's no signal on
the cable. This adds 20 seconds or so to boot time.

Version-Release number of selected component (if applicable):
Fedora 7 test 3, updated as of March 30

Expected result:
The DHCP daemon should see that there's no signal on the cable and terminate
directly.
Comment 1 David Cantrell 2007-04-05 13:38:10 EDT
This is happening because of something in initscripts.  The settings in
/etc/sysconfig/network-scripts/ifcfg-* are being ignored for some reason and the
network service is running DHCP for everything.

Reassigning.  See also bug #234764.
Comment 2 Bill Nottingham 2007-04-05 23:26:11 EDT
What's your ifcfg file?
Comment 3 Taco Witte 2007-04-11 07:34:13 EDT
There's a chance that this bug doesn't exist after all. The (secondary, eth1)
NIC on which this error occurred is dead now, so maybe it was dying back then.
Sorry for the wasted time in that case.

If there's a problem, it's probably this: running "dhclient eth0" by hand waits
forever when there's no signal, while running DHCP through Network Confguration
and /etc/init.d/networking correctly terminates with the message that there's no
signal on the cable.

I don't have the original configuration files anymore alas.
Comment 4 Bill Nottingham 2007-04-11 15:41:22 EDT
dhclient doesn't do a link check, so it may wait forever (modulo whatever normal
dhcp timeouts it has). The ifup script that calls dhclient is what has the link
test.

However, this particular issue (networking going strange on first bootup) has
been reported enough that it's obviously a real issue.
Comment 5 Bill Nottingham 2007-04-12 14:53:40 EDT

*** This bug has been marked as a duplicate of 234764 ***

Note You need to log in before you can comment on or make changes to this bug.