Bug 234660 - Regression on CD install
Regression on CD install
Status: CLOSED DUPLICATE of bug 225026
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-30 16:39 EDT by Trever Adams
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 11:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2007-03-30 16:39:40 EDT
Description of problem:
Ok, test 2 and FC6 on all my machines I could install from CD. Now, all but
those with Plextor drives will boot, but I get asked if I want to install from
hard disk, cd, ftp, and http. If I choose cd, it says it cant find the install.
This seems to be a regression that should be simple to fix. Why is it drive
dependent? (Some of these are SATA and some are PATA systems. The SATAs are the
ones I have had the best luck with, but I believe one PATA (the only PATA
Plextor I have) works).

Version-Release number of selected component (if applicable):
F7test3

How reproducible:
Every time, unless a plextor drive is involved.

Steps to Reproduce:
1. Insert install
2. Watch it ask install source
3. Choose CD, watch it fail
  
Actual results:
Failure to find install media

Expected results:
Should work. Worked in FC6 and I believe test 2

Additional info:
When I say CD, I am meaning DVD. All these systems have DVD readers. The
Plextors are all DVD writers.
Comment 1 Trever Adams 2007-03-30 16:40:43 EDT
All SATA systems are DVD writers as well. A few of the PATAs are only readers.
Comment 2 Jeremy Katz 2007-04-02 13:08:43 EDT
Is it drive or controller dependent?  What controller do the non-working
machines have the CD drive attached to?
Comment 3 Simon West 2007-04-02 15:59:08 EDT
I am also experiencing this problem with both of my machines, trying to install
FC7T3 from i386 Prime DVD.
 
My primary machine:  
ECS PN2+ SLI mobo with NVIDIA NForce 680i SLI chipset, 2GB RAM, Core2Duo 6600.
Optical drive is LG (aka HL-DT-ST) DVD REWRITER drive HSA-G10N on IDE Primary
Master. No secondary channel or other IDE drives.
 
My secondary machine:
Asus A7N266-VM mobo with NVIDIA NForce 1 chipset, 512MB RAM, Athlon XP2400+.
Optical drive is MITSUMI DVDROM DM2000-TE on IDE Secondary Slave. Other IDE
devices present.

The install media:
Philips 4x DVD+RW disc, verified burn using Nero 7 Essentials on Win XP x64.
I used this same disc (with FC6 ISO) two weeks ago to install FC6 successfully
on the primary machine.
Comment 4 Trever Adams 2007-04-02 22:46:57 EDT
Two of my machines that work are nVidia 590 chipsets. I will have to retest all
the others to remember which don't work and then find out what chipsets are and
are not working.

I realized today that test2 didn't work on all of them either. FC6 did!
Comment 5 Trever Adams 2007-04-07 21:23:54 EDT
Ok, all my SATA based machines, sans my laptop (chipset coming by Monday night)
work just fine. All of my PATA machines are the ones that don't recognize the
drive (including one Plextor drive which I thought did work, but on checking
didn't). Two of my working systems are Plextor + nVidia 590 (Asus M2N32-SLI
Deluxe Wireless editions). Two nForce 2 systems (A7N8X and A7N8X Deluxe,
slightly different chipsets, but both saying they are nForce 2) are not working,
one with a Plextor.

My laptop doesn't have a Plextor. It is an HP dv6045nr. I believe it is an
nForce 4 chipset, but I am not certain, as stated, forthcoming.

One A7N8X variant has the DVD drive as slave on primary IDE. The other has it as
master on secondary (no slave).

I have two other systems I will test soon, an old HP Athlon based system and an
old Epox motherboard system. I believe both have failed, but I am retesting to
be certain.
Comment 6 Jeremy Katz 2007-04-09 11:30:32 EDT
Okay, these all sound like more cases of sata_nv being chosen over better driver
choices which I fixed in kudzu last week. 

*** This bug has been marked as a duplicate of 225026 ***
Comment 7 Trever Adams 2007-04-09 12:47:30 EDT
That may be. I found that, other than the laptop, which I haven't retested, that
the harddrive isn't being seen either. So, this must be the case.

Note You need to log in before you can comment on or make changes to this bug.