Bug 234685 - rt2500pci drivers does not work
rt2500pci drivers does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-31 04:56 EDT by Igor Jagec
Modified: 2007-11-30 17:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 09:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
step one of attempt to configure wlan0 (104.12 KB, image/png)
2007-04-14 10:44 EDT, Dave Neuer
no flags Details
hardware choices in Wireless Device Configuration (91.06 KB, image/png)
2007-04-14 10:51 EDT, Dave Neuer
no flags Details
debug output from wpa_supplicant (26.08 KB, text/plain)
2007-04-25 08:30 EDT, Dave Neuer
no flags Details

  None (edit)
Description Igor Jagec 2007-03-31 04:56:28 EDT
Description of problem:

rt2500pci kernel module does not work (as I can see, you've implement rt2x00
driver into f7t3 kernel). My rt2500 network card is recognized by
system-config-network tool, I set it up correctly, but it just does not work. If
I boot any of fc6 kernels and compile rt2500 driver manually, it works fine.

Version-Release number of selected component (if applicable):

kernel-2.6.20-1.3023.fc7

How reproducible:

every time

Steps to Reproduce:
1. make the rt2x00 drivers work fine
2.
3.
  
Actual results:

output of system-config-network:

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wmaster0 ; Operation not supported.
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device wmaster0 ; Operation not supported.
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wmaster0 ; Operation not supported.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wmaster0 ; Operation not supported.
_________________________________________

[root@localhost ~]# iwconfig 
lo        no wireless extensions.

wmaster0  IEEE 802.11g  Frequency:2.412 GHz  
          RTS thr:off   Fragment thr=2346 B   
          
wlan0     IEEE 802.11g  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          RTS thr:off   Fragment thr=2346 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
___________________________________________________

[root@localhost home]# iwlist wlan0 scanning
wlan0     No scan results
[root@localhost home]# iwlist wmaster0 scanning
wmaster0  Interface doesn't support scanning : Operation not supported

Expected results:

No output from system-config-network tool, iwlist should scan some networks.

Additional info:
Comment 1 Igor Jagec 2007-03-31 10:05:18 EDT
Just to let you know, I've got the same output for both devices, wlan0 and 
wmaster0. I know that wmaster0 should be left alone. 
Comment 2 Martin Kristensen 2007-03-31 12:42:01 EDT
I get the same problem, the output from iwlist is below. The same error is
generated by the network manager. 

#iwlist wlan0 scanning
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

# lspci |grep -i ralink
00:09.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
Comment 3 Igor Jagec 2007-03-31 22:51:43 EDT
Well, rt2x00 developers hope that rt2x00 driver won't be a part of 2.6.21 
mainline kernel because "it is not ready". Whatever that means...
http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=3567
Comment 4 John W. Linville 2007-04-04 10:16:22 EDT
A patch was applied to the rawhide kernels on 4/1 that may have helped this 
issue.  Have you tried the latest rawhide kernels?
Comment 5 Igor Jagec 2007-04-05 04:52:54 EDT
Yes, and I've got the same output. Plus the one Martin Kristensen has got. I 
tried with kernel-2.6.20-1.3040.fc7.i686
Comment 6 Matthew Miller 2007-04-10 12:32:09 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 7 Dave Neuer 2007-04-12 12:24:09 EDT
Had the same problem but moving to kernel-2.6.20-1.3056.fc7 fixed it for me,
however, I have to setup the interface manually like so:

wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

The Network Configuration application in the Gnome "System" menu can't configure
it because it thinks the actual hardware interface is (the totally useless,
apparently) wmaster0 (there doesn't seem to be a way to make it use wlan0).
Comment 8 John W. Linville 2007-04-13 13:30:11 EDT
Please try the test kernels here:

   http://people.redhat.com/linville/kernels/fc7/

Do these kernels work any better for you?
Comment 9 Dave Neuer 2007-04-13 15:45:53 EDT
(In reply to comment #8)
> Please try the test kernels here:
> 
>    http://people.redhat.com/linville/kernels/fc7/
> 
> Do these kernels work any better for you?

Who should test these? As I said, kernel-2.6.20-1.3056.fc7 from the main
development section of the mirrors made the interface work if configured
manually w/ wpa_supplicant; do the kernels at the URL above fix something else?
Comment 10 John W. Linville 2007-04-13 15:55:12 EDT
You complained about tools trying to access wmaster0.  Does that problem 
continue with the kernels I posted?
Comment 11 Igor Jagec 2007-04-14 05:40:09 EDT
(In reply to comment #8)
> Please try the test kernels here:
> 
>    http://people.redhat.com/linville/kernels/fc7/
> 
> Do these kernels work any better for you?

# rpm -ivh *
error: Failed dependencies:
        /usr/src/kernels is needed by kernel-devel-2.6.20-
1.3056.2.1.fc7.jwltest.8.i686

Of course, I have /usr/src/kernels directory.

I got the 2.6.20-1.3062.fc7 with updates and it works. I'm not sure how stable, 
but my network works for now. But, I still got all the errors I copy/pasted 
above.

I'm not sure if that's a good idea to include rt2x00 drivers since their 
developers says it is not stable: http://rt2x00.serialmonkey.com/phpBB2/
viewtopic.php?t=3567 From the other hand, I still can't compile legacy rt2500 
drivers on Rawhide.
Comment 12 Dave Neuer 2007-04-14 10:44:31 EDT
Created attachment 152613 [details]
step one of attempt to configure wlan0
Comment 13 Dave Neuer 2007-04-14 10:46:39 EDT
Oops, didn't realize attachments were sent separately.

No, 2.6.20-1.3056.2.1.fc7.jwltest.8 doesn't fix the problems for me.

I've attached some screenshots which show what I see in the Network
Configuration application. Basically, it seems like the only thing that's
changed w/ this kernel   is that in the "Device" dropdown of the "Network
Adaptor Configuration" tab of the application now lists eth0..eth8 instead of
wmaster0..wmaster8. The "Hardware Device" tab of the Wireless Device
Configuration still only offers wmaster0..wmaster8 as you can see.

Everything still works fine w/ manual wpa_supplicant + dhclient wlan0 (though
the final attached screenshot shows that there are a few errors reported when
wpa_supplicant is run; they are spurious or inconsequential).

Sorry about the image size of the screenshots, they're as small as I could get
them w/ the GIMP while leaving the text readable.
Comment 14 Dave Neuer 2007-04-14 10:51:01 EDT
Created attachment 152615 [details]
hardware choices in Wireless Device Configuration

What I see after selecting "edit" in screen from previous attachment, then
navigating to "hardware" tab and trying to select something besides the default
(wmaster0).
Comment 15 Dave Neuer 2007-04-14 10:53:21 EDT
[root@gemini ~]# wpa_supplicant -B -D wext -i wlan0 -c
/etc/wpa_supplicant/wpa_supplicant.conf
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - [root@gemini ~]# 

All still works fine after this and dhclient wlan0
Comment 16 Dave Neuer 2007-04-18 16:56:47 EDT
(In reply to comment #11)
> 
> I'm not sure if that's a good idea to include rt2x00 drivers since their 
> developers says it is not stable: http://rt2x00.serialmonkey.com/phpBB2/
> viewtopic.php?t=3567 From the other hand, I still can't compile legacy rt2500 
> drivers on Rawhide.

Right, unless the legacy drivers compile _and_work_, I think this driver has to
be included, as there are plenty of these cards out there.

That said, I don't care if for a while I have to manually run wpa_supplicant and
dhclient. Aside from bringing up the interface, I've had zero problems w/ the
driver.
Comment 17 John W. Linville 2007-04-24 14:26:04 EDT
Dan, can you shed light on what wpa_supplicant does not appear to work when 
invoked by NM?
Comment 18 Dan Williams 2007-04-24 16:05:47 EDT
rt2500 is a lost cause until they support WE-18 and later (ie, standard WPA
config stuff).  Plus, AIUI, there's an rt2x00 mac80211 based driver.  If
somebody really wants to do the work of porting rt2x00 to WE-18 (ie adding
get/set for IWAUTH, IWENCODEEXT, and IWGENIE) that's fine, but it's pretty much
a dead end.

I also don't have an rt2x00 card anywhere, though perhaps Ed Rousseau's recent
CDW shopping spree caused one to turn up in Westford.
Comment 19 John W. Linville 2007-04-24 16:10:18 EDT
Perhaps I misread something...Dave, are you building the legacy rt2x00 drivers 
from their CVS tree (or installing from an rpm, etc)?  Or are you using the 
ones currently in rawhide?
Comment 20 Dan Williams 2007-04-24 16:36:30 EDT
I'm somewhat confused too...  there's about 4 different versions of rt2x00
floating around.

a) legacy versions, the "latest BETA" ones here at the top:
http://rt2x00.serialmonkey.com/wiki/index.php?title=Downloads

b) the "bleeding edge" versions of (a)

c) the more recent version based on an old d80211 stack
http://rt2x00.serialmonkey.com/rt2x00-cvs-daily.tar.gz

d) rt2x00 in wireless-dev (mac80211-based)

e) Ivo's upstream rt2x00 (mac80211-based)

(a), (b), and (c) are completely useless and should not be used.  If we're
talking about either (d) or (e), then we care...  Looking back over the
comments, I assume that we're talking about (d) or (e) because that's what's in
wireless-dev and in the rawhide test kernels, right?
Comment 21 Dan Williams 2007-04-24 16:38:37 EDT
Dave:

can you try the test again with:

[root@gemini ~]# wpa_supplicant -ddd -D wext -i wlan0 -c
/etc/wpa_supplicant/wpa_supplicant.conf

and post the output, attaching it as a file?
Comment 22 Dave Neuer 2007-04-25 07:55:18 EDT
(In reply to comment #19)
> Perhaps I misread something...Dave, are you building the legacy rt2x00 drivers 
> from their CVS tree (or installing from an rpm, etc)?  Or are you using the 
> ones currently in rawhide?

I'm using the rawhide version, and it works, as long as I run wpa_supplicant and
dhclient manually.

Comment 23 Dave Neuer 2007-04-25 08:14:40 EDT
(In reply to comment #17)
> Dan, can you shed light on what wpa_supplicant does not appear to work when 
> invoked by NM?

John, to be clear: I'm not using NM, I haven't even figured out how to get the
applet in my panel.

Rather, it's the network scripts in /etc/sysconfig and the "Network
configuration" application (system-config-network is the name I see doing 'ps',
it's a python app).
Comment 24 Dave Neuer 2007-04-25 08:30:38 EDT
Created attachment 153415 [details]
debug output from wpa_supplicant

(In reply to comment #21)
> Dave:
> 
> can you try the test again with:
> 
> [root@gemini ~]# wpa_supplicant -ddd -D wext -i wlan0 -c
> /etc/wpa_supplicant/wpa_supplicant.conf
> 
> and post the output, attaching it as a file?

Here you go.
Comment 25 Vic Ricker 2007-05-23 11:51:53 EDT
Hi.

I'm having problems with the rt2500 as well.  I am using it with NetworkManager.
 Someone asked how to get the applet in the panel: service NetworkManager start.

Soemtimes the driver works but it would take several minutes of fiddling with
NetworkManager to get it working.  For example, sometimes it wouldn't show any
wireless networks.  Sometimes it would show only my neighbor's network. 
Sometimes I could enter my SSID and get it to connect manually.  Sometimes it
just wouldn't work at all.  Sorry, I guess that's not very technical.  I just
didn't want to say, "me too!"  :-)

I didn't try very hard but I wasn't able to configure it statically and 'ifup
wlan0'  Which is how I used to do it under FC6 with the driver that I built from
CVS.

My access point is wide open.  I have it firewalled off and don't even use WEP.

Another problem that I noticed is that the driver prevents my laptop from
resuming from suspend.  I was able to get around the problem with the
instructions here http://people.freedesktop.org/~hughsient/quirk/quirk-advanced.html
by having it unload the rt2500pci module.

Comment 26 Igor Jagec 2007-06-03 07:01:20 EDT
The problem still persists in Fedora 7. How the heck we can remove rt2500pci and
install legacy rt2500? I'm affraid I'll have to stick with fc6 if someone
doesn't fix that problem. 

Thanks.
Comment 27 Dave Neuer 2007-06-03 13:33:38 EDT
(In reply to comment #26)
> The problem still persists in Fedora 7. How the heck we can remove rt2500pci and
> install legacy rt2500? I'm affraid I'll have to stick with fc6 if someone
> doesn't fix that problem. 
> 
> Thanks.

NAK.

I have overall stability issues w/ the kernel on the release version, but the
wireless stuff appears to work for me w/out issue: the network scripts at
startup use wlan0 instead of wmaster0, and using NetworkManager to connect to my
wireless router using WPA-TKIP works just fine.

I'm using NM instead of the static scripts, since the machine is a laptop, but I
strongly suspect that the static scripts would work if I provided my WPA
passphrase (since the problem w/ the static scripts previously was attempting to
pick the wrong interface).

Note: I did a fresh install of the release, rather than an upgrade from test.
Comment 28 Igor Jagec 2007-06-03 13:58:51 EDT
I did fresh install on my test partition, set up network with system-config-
network, and network sometimes works, sometimes not.
Comment 29 Igor Jagec 2007-06-04 04:42:49 EDT
I solved the problem.

# rm -rf /lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/mac80211/
rt2x00; depmod

Then I compiled CVS version of legacy rt2500 drivers and now everything works 
just fine. Here's where you can download it: http://rt2x00.serialmonkey.com/
wiki/index.php/Downloads

Cheers!
Comment 30 Heiko Adams 2007-06-07 06:54:31 EDT
I got the same problem here. Fedora 7 was fresh installed, my rt2500 chip was
identified correctly but I can't connect to my router neither with static
configuration nor with NM or WPA_Suplicant. The only "error" message I got was
that fetching DHCP Informations failed.
Because a not-working WLAN driver is a no-go for me I rolled back the Fedora 7
installation and installed fedora core 6 until someone tells me that the rt2x00
driver works relieable or fedora provides the legacy driver as an rpm.
Comment 31 Jean-Jacques Sarton 2007-06-10 07:10:45 EDT
On a fresh installed F7 the hardware freezed. After a few update (but none for the
kernel !) freeze was no more observed.
The behaviour of the rt2xx components is very stange, there are no reproductible
behaviours (with the exeption that this don't worl).

An alternative is to disable the rt2xx modules within the file
/etc/modeprobe.d/blacklist:

blacklist rc80211_simple
blacklist rt2500pci
blacklist rt2x00pci
blacklist rt2x00lib
blacklist mac80211
blacklist cfg80211
blacklist eeprom_93cx6

Using the old driver from the rt2xx page work fine, the only "problem" is that
master mode is not supported.
Comment 32 Caolan McNamara 2007-06-14 16:14:41 EDT
FWIW: on rawhide x86_64 2.6.21-1.3218.fc8 the rt2500pci wireless now works for me.
Comment 33 Caolan McNamara 2007-06-14 16:15:52 EDT
"with NetworkManager" I should probably add
Comment 34 Ruben Toledo 2007-06-17 10:56:01 EDT
Hi. Im have an rt61 pcmcia wifi card D-Link DWL-G630 rev E, to work I compile
the serialmonkey rt61 module, install, up the network eth0 (another card) then
insert the card, and... voila! its work! including wlassistant.

thanks

fc7, 2.6.21-1.3228.fc7, pentium4, 512ram.
Comment 35 Ruben Toledo 2007-06-17 10:57:58 EDT
Im forgot... if only try with the default rt61 in the kernel, it didn't work
Comment 36 Karsten Wade 2007-06-20 20:08:12 EDT
Someone flagged this as fedora_requires_release_note.  Please note in a comment
what you think needs to be in a release notes (update?) for which version of
Fedora, or remove the flag.  Thanks.
Comment 37 John W. Linville 2007-07-16 16:58:47 EDT
Does this problem persist w/ current rawhide kernels (e.g. 
kernel-2.6.23-0.29.rc0.git6.fc8 or later)?
Comment 38 Vic Ricker 2007-07-17 09:31:04 EDT
I've found a workaround, sort of.  With the rt2500, the network rarely comes up
when I first login.  (Using NetworkManager)  Sometimes I'd have to wait 15-30
minutes before it would start working.

While playing around, I discovered that by running 'iwlist wlan0 scanning'
repeatedly (usually 5-10 times), I could get it to see my AP.  As soon as the AP
shows in iwlist, NetworkManager will connect automatically.  Once it gets
connected, everything works fine for the rest of the session.

I'm using 2.6.21-1.3228.fc7.
Comment 39 Igor Jagec 2007-07-18 04:11:46 EDT
(In reply to comment #37)
> Does this problem persist w/ current rawhide kernels (e.g. 
> kernel-2.6.23-0.29.rc0.git6.fc8 or later)?

Well, everything seems to be working fine on first booting of 2.6.23-
0.29.rc0.git6.fc8. But the GNOME network applet still shows 0% signal strength, 
even if network work just fine. I have no such problems with legacy rt2500.
Comment 40 John W. Linville 2007-07-18 09:11:08 EDT
Closing this as fixed in RAWHIDE.  Please open a new bug regarding the issue 
you describe with GNOME network applet.

Note You need to log in before you can comment on or make changes to this bug.