Bug 234728 - KDE Live CD install fails
KDE Live CD install fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC7Blocker Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-03-31 18:48 EDT by Linus Torvalds
Modified: 2013-01-09 23:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-17 12:30:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2007-03-31 18:48:45 EDT
Description of problem:

 Trying out the Fedora-7-Test3-KDE-Live.iso on my MacMini causes what
 appears to be a perfectly working livecd, and I can run the "Install
 to harddisk" fine, and it appears to succeed.

 But rebooting the machine it halts early in bootup, complaining about
 not being able to find any "init".


Version-Release number of selected component (if applicable):

  Fedora-7-Test3-KDE-Live.iso

How reproducible:

  Tried it twice, just to make sure. Then tried the normal (gnome) LiveCD
  to see if that also shows the same problem, but that one installed fine,
  and my Mac Mini is now in the middle of doing a "yum upgrade"

Steps to Reproduce:
1. Get Fedora-7-Test3-KDE-Live.iso image, burn it, boot it
2. "Install to Harddisk"
3. reboot, watch it claim there is no "init".
  
Actual results:

  Nonworking install

Expected results:

  Purdy KDE desktop booting from harddisk

Additional info:

  I love the LiveCD. I hope I never ever need to install any other way.
  But I'd like to have the choice of the KDE version..
Comment 1 David Zeuthen 2007-04-01 05:42:21 EDT
I seem to remember some thread on either fedora-livecd-list or fedora-devel-list
about this bug but can't find them right. Anyway, anaconda is the most likely
suspect (perhaps it's just a missing RPM Requires) so moving the bug there and
making this a blocker bug.
Comment 2 David Zeuthen 2007-04-01 05:44:18 EDT
(it usually works better if I actually reassign the bug; sorry about that)
Comment 3 David Zeuthen 2007-04-01 05:52:10 EDT
Btw, here's a link with more discussion of this bug

 https://www.redhat.com/archives/fedora-livecd-list/2007-March/msg00269.html

It's probably going to be a lot easier to pinpoint the root problem when the KDE
kickstart file lands in the livecd git repo

 http://git.fedoraproject.org/?p=hosted/livecd
Comment 4 G.Wolfe Woodbury 2007-04-01 18:41:00 EDT
also observed on the work1 Coppermine Pentium @600MHz.  MSI mobo/VIA chipset.
no exceptions or errors reported.
Comment 5 Sebastian Vahl 2007-04-03 17:44:57 EDT
Thanks for confirming this bug. I've seen this before on my local machine but
was not sure if this would happen elsewhere. Sadly I have no idea why this
happens (and not on the gnome one, too). I can could only suggest a workaround
for test3: http://fedoraproject.org/wiki/Releases/FeatureFedoraKDE/KDELiveCD/Test3
Comment 6 Jeremy Katz 2007-04-03 18:27:43 EDT
Have a bit of a hacky workaround in the anaconda that will be in tomorrow's
rawhide.  Going to continue to look into what's going on, though, and hopefully
get the real fix in time for test4
Comment 7 Sebastian Vahl 2007-04-04 09:28:33 EDT
(In reply to comment #6)
> Have a bit of a hacky workaround in the anaconda that will be in tomorrow's
> rawhide.  Going to continue to look into what's going on, though, and hopefully
> get the real fix in time for test4

Great! anaconda-11.2.0.44-1 works for me. Installation is bootable again without
the workaround.
I've tested this in two ways:
1. with an actual spin of the KDE-LiveCD
2. updated anaconda and kudzu directly on the livecd before installation

Comment 8 Jeremy Katz 2007-04-17 19:21:09 EDT
What's there now is what we're going to go with for Fedora 7.  Bigger changes
will come after that.
Comment 9 Sebastian Vahl 2007-04-17 19:26:22 EDT
For the record: I haven't encountered this bug since comment #7

Note You need to log in before you can comment on or make changes to this bug.