Bug 23473 - Problem in locale Compose file for iso8859-1
Summary: Problem in locale Compose file for iso8859-1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-06 06:20 UTC by Eli Barzilay
Modified: 2007-03-27 03:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 21:08:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eli Barzilay 2001-01-06 06:20:19 UTC
The default settings in
  /usr/X11R6/lib/X11/locale/iso8859-1/Compose
make Control+Shift+T act like a Multi_key.  This is really not needed since
you can use only
the Multy_key bindings and actually assign any key you want to Multi_key. 
I encountered
this problem while playing with my Emacs configuration, and discussed it
with Emacs'
developers.  It seems like this problem originates in X itself since I saw
the same problem with
the default files on Solaris.  (I also mailed the XFree86 list but got no
response so far).

Comment 1 Mike A. Harris 2001-03-15 17:23:45 UTC
I really do not know much about that stuff.  Can you suggest a proper
fix, and perhaps attach a patch file, or something and I can run it
by some other developers and possibly include it in a future release?

Comment 2 Mike A. Harris 2001-03-17 19:14:25 UTC
I've looked in to this and I now know the file layouts partially,
but am still not completely certain what if anything to change as i do
not use any of this stuff at all and I don't want to break it.

Tis a side effect of being unilingual and using the default en_US layouts
with no special needs.  ;o)  I will try to dig into this, but please try
to explain the problem a little more detailed to me.

Comment 3 Eli Barzilay 2001-03-17 19:30:08 UTC
Well, I also use just the standard isso8859-1 - which is what originated the
problem...
The thing is that this file has definitions for key combinations to get all
kinds of accented
characters etc.  Actually, it has three parts - one with Multi_key, a quick
thing with dead_acute
and the last part is almost an exact copy of the Multi_key thing with Ctrl<T>
instead.
Now this thing makes it possible to get accented keys with C-S-t, which is bogus
since you have bindings for Multi_key anyway - so if you realy want to use
C-S-t, you can use your .xmodmap
or whatever to modify it so it produces a Multi_key, and this will be an
identical thing.
So what I suggest is just killing the whole Ctrl<T> section, I don't expect
anyone to really use it.
One reason I can say that last sentence is that from digging around I learned
that once the French 
Compose file had the same binding for C-S-t, but it was removed.  Funny that
only the English
one is the one left with this junk...

Comment 4 Mike A. Harris 2001-03-17 21:08:31 UTC
Ok, I think I get the idea now.  I will see what i can squeeze it into
my next build.

Comment 5 Mike A. Harris 2001-04-26 02:17:40 UTC
Ok, I've added it to 4.0.3-11


Note You need to log in before you can comment on or make changes to this bug.