Bug 234740 - thttpd as delivered with FC7T3 fails to start
thttpd as delivered with FC7T3 fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thttpd (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-01 05:49 EDT by Bernd Bartmann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.25b-13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 19:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2007-04-01 05:49:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Description of problem:
FC7T3 comes with thttpd. During boot thttpd fails to start with "unknown user".

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. install FC7T3 including thttpd
2. watch out of the boot messages of thttpd
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Matthias Saou 2007-04-02 04:20:54 EDT
This is really strange. I just tested installing and starting thttpd and all
went fine. Can you please check :
- If the thttpd user was created properly, for instance :
  grep thttpd /etc/passwd
- If the service wrote anything special to /var/log/messages (search for thttpd)
Comment 2 Bernd Bartmann 2007-04-03 11:40:02 EDT
There is no user "thttpd" in /etc/passwd and /var/log/messages only contains
thttpd[2833]: unknown user - 'thttpd'
Comment 3 Bernd Bartmann 2007-04-27 12:54:10 EDT
The problem still exists in FC7T4.
Comment 4 Matthias Saou 2007-05-04 09:21:23 EDT
Strange, very strange. Can you maybe manually run the %pre commands?

/usr/sbin/groupadd -r www
/usr/sbin/useradd -s /bin/false -c "Web server user" \
    -d /var/www/thttpd -M -r -g www thttpd

And write here what those commands give you...
Comment 5 Bernd Bartmann 2007-05-04 11:09:33 EDT
If run from a root shell both commands return without any message. The group is
successfully created in /etc/group:
www:x:491:

The user is also successfully created in /etc/passwd:
thttpd:x:492:491:Web server user:/var/www/thttpd/:/bin/false

Also service thttpd start now works and gives [ok]

But I found this in the install.log from anaconda:
thttpd - 2.25b-12.fc6.x86_64 installieren

warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root
warning: user thttpd does not exist - using root
warning: group www does not exist - using root

Looks like %pre does not get executed at all.
Comment 6 Matthias Saou 2007-05-04 11:16:27 EDT
This looks more like a bug in anaconda, then...
Maybe it's not even worth digging, since I doubt thttpd will be shipped by
default in F7 (I really hope it isn't! lighttpd is soooo much better! ;-))
Comment 7 Will Woods 2007-05-25 17:40:15 EDT
Still in F7 RC2.
Comment 8 Tom Horsley 2007-06-02 09:19:58 EDT
Well, all of these show up when I install lots of stuff from the f7 DVD:

/etc/rc.d/init.d/httpd     /etc/rc.d/init.d/tclhttpd
/etc/rc.d/init.d/lighttpd  /etc/rc.d/init.d/thttpd

And once again, there is no thttpd user (though there is a tclhttpd user).
Comment 9 Matthias Saou 2007-06-19 13:57:30 EDT
It was a silly matter of missing scriplet requirements, with thttpd getting
installed before useradd/groupadd. This is now fixed, but not on the F7 media,
obviously. Still, thttpd shouldn't be there... it's an old-ish http server which
has many good replacements.
Comment 10 Fedora Update System 2007-06-19 17:37:35 EDT
thttpd-2.25b-13.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2007-06-25 19:25:22 EDT
thttpd-2.25b-13.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.