Bug 23477 - pump uses wrong addresses for sending DHCP requests
pump uses wrong addresses for sending DHCP requests
Status: CLOSED DUPLICATE of bug 23052
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-01-06 05:16 EST by Guy Van Den Bergh
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-16 09:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Guy Van Den Bergh 2001-01-06 05:16:39 EST
My situation is the following: I have a home LAN, and internet access
through a cable modem. I have 192.168.1.x addresses on the LAN, and my
cable ISP gives me  1 public address through DHCP. That's where pump comes
in the pic...
I use a RedHat 6.2 box for doing NAT, where eth0 is the LAN side, and eth1
the cable modem side.
At boot time, first eth0 is configured with a private address. Then eth1 is
configured, but pump uses the private address from eth0 instead of The result is that I get no response from the DHCP server...
When I disable eth0 at boot time, everything is working fine, I get an IP
address and so on.
Only eth1 will be configured now and no address is defined (yet)) at eth0.
Pump uses in this case, and it works fine.
btw, I've been troubleshooting this one with tcpdump, and it took a while
before I figured what went wrong...
Comment 1 Guy Van Den Bergh 2001-01-06 05:24:33 EST
To be clear: the DHCP DISCOVER going out on eth1 uses as
destination address, and the address configured at eth0 (192.168.x.x) as source
address, seen with tcpdump.
Comment 2 Eugene Kanter 2001-04-06 11:54:51 EDT
clearly seems like a duplicate of 23052. Any comments, Erik?
Comment 3 Guy Van Den Bergh 2001-04-06 19:29:37 EDT
Yep. This is indeed a duplicate of 23052.
Comment 4 Elliot Lee 2001-08-08 00:23:30 EDT

*** This bug has been marked as a duplicate of 23052 ***

Note You need to log in before you can comment on or make changes to this bug.