Bug 234813 - libsane-hpaio problems with OOo
libsane-hpaio problems with OOo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-04-02 05:40 EDT by Caolan McNamara
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.7.2-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 04:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2007-04-02 05:40:25 EDT
Description of problem:
in FC-6/FC-7 in OOo, insert->picture->scan->anything == crash

Version-Release number of selected component (if applicable):
hplib >= 1.6.12

How reproducible:
100%

nm -D ./usr/lib/sane/libsane-hpaio.so.1.0.0 | grep sanei
         U sanei_debug_msg
         U sanei_init_debug

but it doesn't link against libsane, which is fine when it's dlopened from
libsane, but a problem when dlopened from OOo.
Comment 1 Tim Waugh 2007-04-03 07:59:57 EDT
The problem is that SANE doesn't provide any mechanism for building drivers
outside its tree. :-/

I'll take a look at how to fix this.
Comment 2 Tim Waugh 2007-04-03 08:54:30 EDT
Fixed in CVS for FC-6 and devel.
Comment 3 Tim Waugh 2007-04-11 13:09:03 EDT
RHEL-5 is not affected.
Comment 4 Fedora Update System 2007-04-18 18:35:27 EDT
Fixed in update: hplip-1.7.2-3.fc6

Note You need to log in before you can comment on or make changes to this bug.