Bug 23484 - Misbehaviour of the ALT key in gnome-terminal
Summary: Misbehaviour of the ALT key in gnome-terminal
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-06 13:24 UTC by vigna
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 15:45:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vigna 2001-01-06 13:24:48 UTC
In gnome-terminal, the ALT modifier does not emit characters with the
eighth bit raised as usual (e.g., in xterm), but rather prefixes the
character with ESC. This is OK with the shell because bash is configured so
to espect such sequences, but it DOES NOT WORK with all applications
expecting the eighth bit raised. It should be AT LEAST an option for the
user to have the standard xterm behaviour (eighth bit raised) or the ESC
prefix.

In any case, the second problem is the the TAB key *does not get the
prefix!*. It is the only key to behave in such a way. So the standard
binding for Meta-TAB (or \M-\C-\t), dynamic-complete-history, does not work
(you have to manually press ESC and TAB). Note that I use CTRL-TAB in
sawfish for window cycling, so the keypress actually gets to gnome-terminal.

Even in the case you do not think it's a good idea to fix the first
problem, you should definitely fix the second one...

Comment 1 Havoc Pennington 2001-01-08 15:45:36 UTC
Sounds reasonable to me, will forward upstream to gnome-terminal maintainer.

Comment 2 Havoc Pennington 2001-07-12 19:36:28 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=57455

Closing on RH level


Note You need to log in before you can comment on or make changes to this bug.