Bug 23489 - g++ core dump on a segmentation violation
Summary: g++ core dump on a segmentation violation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-06 16:36 UTC by Göran Uddeborg
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-22 17:09:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
C++ source triggering a segmentation violation in g++ (28.53 KB, text/plain)
2001-01-06 16:38 UTC, Göran Uddeborg
no flags Details
Log from running the commands. (1.63 KB, text/plain)
2001-01-07 20:48 UTC, Göran Uddeborg
no flags Details
Ball.ii as requested (436.79 KB, text/plain)
2001-01-07 20:50 UTC, Göran Uddeborg
no flags Details

Description Göran Uddeborg 2001-01-06 16:36:33 UTC
Calling g++ like this

g++ -c -O3 -o ball.o ball.cc

on the enclosed input file causes g++ to dump core.  This is with with the
updated gcc-c++-2.96-69 version of the compiler.  I have tried to reduce
the example further, but it the problem disappears for most things I remove
now.  Even if I do things like removing the second #include of a file which
has already been included.

(For correct credits: the original source came from the tunnel game
http://www.eng.um.edu.mt/~tbspit/tunnel version 20000913.)

Comment 1 Göran Uddeborg 2001-01-06 16:38:07 UTC
Created attachment 7143 [details]
C++ source triggering a segmentation violation in g++

Comment 2 Jakub Jelinek 2001-01-07 10:46:14 UTC
Cannot reproduce this (perhaps you have some headers different to
what I have installed). Can you perhaps run
g++ -c -O3 -o ball.o ball.cc -save-temps -v
then try if
g++ -c -O3 -o ball.o ball.ii
reproduces it as well and attach here ball.ii if yes?

Comment 3 Göran Uddeborg 2001-01-07 20:45:21 UTC
I upbraded glibc-2.2 from release 5 to 9 to check if that was the relevant
difference, but it doesn't seem to be.  I still get the dump. Is there any other
package involved which I should check?  Gcc doesn't seem to depend on much else.

Anyway, I include ball.ii as requested.  I also enclose a script log showing the
output when I ran the commands. As you can see, the bug is still there.


Comment 4 Göran Uddeborg 2001-01-07 20:48:28 UTC
Created attachment 7205 [details]
Log from running the commands.

Comment 5 Göran Uddeborg 2001-01-07 20:50:12 UTC
Created attachment 7206 [details]
Ball.ii as requested

Comment 6 Jakub Jelinek 2001-01-18 14:42:51 UTC
Fixed in CVS g++ today (well, it did not segfault on it but the bug was still
there), plus the patch will appear in gcc-c++-2.96-71


Note You need to log in before you can comment on or make changes to this bug.