Bug 23496 - IDE CD-R with SCSI-emul. has "retryable errors"
IDE CD-R with SCSI-emul. has "retryable errors"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-06 16:42 EST by Thilo Mezger
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thilo Mezger 2001-01-06 16:42:40 EST
AFAIK, this is a well-known problem and has been reported by many people on
the kernel mailing list before (without solution) but I'm filing it under
"cdrecord" here anyway.

I've set up IDE-SCSI emulation to use an old Mitsumi CR-2801TE to burn
CD's.  This works not very well under RHL7 and often stops with errors like
this:

----------------
cdrecord: Input/output error. write_g1: scsi sendcmd: retryable error
CDB:  2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 06 00 00 00 00 30 05 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x30 Qual 0x05 (cannot write medium - incompatible format) Fru
0x0
Sense flags: Blk 0 (not valid)
-----------------

The drive has worked before (probably with an unpatched 2.2.16 kernel) but
I get lots of problems with RHL7's 2.2.16-22 kernel.
Comment 1 Mikko Korhonen 2001-03-11 05:26:14 EST
For one reason or the other having the cd-writer as
the only device on the ide-bus seems to help.
(Cd-writer as master and no slave device.)
Comment 2 Kirk 2001-04-01 12:35:17 EDT
I have the same problem.  I have a Philip's CDD3610 clone as the slave and a
Mitsumi on the master.  Both are on the secondary ide channel.  I admit that I
do not use the CD writer much, so I am not sure where it went bad.  I know that
I used it on Redhat 6.2 with a recompiled kernel with no problem.  I also think
that I used it on the original 7.0 before all of the updates.  I still have the
original 7.0 kernel installed in Lilo, but the drive still doesn't work when I
boot with it.  I have both my CDROM and CDR installed using SCSI emulation, but
again I never noticed a problem at that time.  I may go back and install the 6.2
kernel, recompile it and see if it works.  Hopefully, this will work again in
the 2.4 series.
Comment 3 Crutcher Dunnavant 2001-04-04 17:11:51 EDT
> AFAIK, this is a well-known problem and has been reported by many people on
> the kernel mailing list before (without solution) but I'm filing it under
> "cdrecord" here anyway.

Why? Refiling.
Comment 4 Leo Lopes 2001-06-10 10:14:52 EDT
I think having this bug filed under cd-paranoia is not a bad thing. I wished I
could find it when I searched specifically under that package. In fact, it would
be nice if the bugzilla system allowed us to file under more than one package.
Comment 5 Leo Lopes 2001-06-11 09:19:04 EDT
I meant cdrecord, of course...
Comment 6 Bugzilla owner 2004-09-30 11:38:53 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.