Bug 23498 - Guinness has conflicting versions of jni.h
Summary: Guinness has conflicting versions of jni.h
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kaffe   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-07 02:27 UTC by Lee Howard
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 02:27:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lee Howard 2001-01-07 02:27:40 UTC
[root@metroid deanox]# ls -l /usr/include/kaffe/jni.h
-rw-r--r--    1 root     root        28008 Aug  8 
18:13 /usr/include/kaffe/jni.h
[root@metroid deanox]# ls -l /usr/include/jni.h
-rw-r--r--    1 root     root        55060 Aug 21 02:54 /usr/include/jni.h
[root@metroid deanox]# rpm -qf /usr/include/kaffe/jni.h
kaffe-1.0.6-2
[root@metroid deanox]# rpm -qf /usr/include/jni.h
libgcj-devel-2.96-22
[root@metroid deanox]#

How do these not conflict?

Comment 1 Bill Nottingham 2001-01-07 02:53:20 UTC
They're not in the same place.

Comment 2 Lee Howard 2001-01-07 03:08:32 UTC
Try compiling pdflib-3.03 with the java option, or any other code that 
recurses /usr/include to find jni.h, and you'll see that if it really needs the 
jni.h in /usr/include/kaffe that it cannot find it because it runs into the one 
in /usr/include first.

But since *neither* jni.h prevent pdflib-3.03 from failing to compile 
properly... maybe I should just say that *both* are broken.?


Note You need to log in before you can comment on or make changes to this bug.