Bug 235055 - /usr/sbin/rpc.gssd segfaults on ppc
/usr/sbin/rpc.gssd segfaults on ppc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
: 241106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 12:24 EDT by Jakub Hrozek
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version: nfs-utils-1.0.6-80
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 19:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2007-04-03 12:24:15 EDT
Description of problem:
This was found during errata testing of 2007:9143.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep ^nfs
nfs-utils-lib-1.0.6-7
nfs-utils-lib-devel-1.0.6-7
nfs-utils-lib-debuginfo-1.0.6-7
nfs-utils-1.0.6-78.EL4
nfs-utils-debuginfo-1.0.6-78.EL4

How reproducible:
# /usr/sbin/rpc.gssd -f -vvv

Steps to Reproduce:
1. see above
  
Actual results:
# /usr/sbin/rpc.gssd -f -vvv
Using keytab file '/etc/krb5.keytab'
ERROR: No such file or directory while beginning keytab scan for 
keytab '/etc/krb5.keytab'
ERROR: No usable keytab entries found in keytab '/etc/krb5.keytab'
Do you have a valid keytab entry for nfs/<your.host>@<YOUR.REALM> in keytab 
file /etc/krb5.keytab ?
Continuing without (machine) credentials - nfs4 mounts with Kerberos will fail
processing client list
Segmentation fault


Expected results:
no segfault

Additional info:
---gdb session---
gdb /usr/sbin/rpc.gssd
GNU gdb Red Hat Linux (6.3.0.0-1.132.EL4rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "ppc64-redhat-linux-gnu"...Using host libthread_db 
library "/lib64/tls/libthread_db.so.1".

(gdb) set args  -f -vvv
(gdb)  run
Starting program: /usr/sbin/rpc.gssd -f -vvv
Using keytab file '/etc/krb5.keytab'
ERROR: No such file or directory while beginning keytab scan for 
keytab '/etc/krb5.keytab'
ERROR: No usable keytab entries found in keytab '/etc/krb5.keytab'
Do you have a valid keytab entry for nfs/<your.host>@<YOUR.REALM> in keytab 
file /etc/krb5.keytab ?
Continuing without (machine) credentials - nfs4 mounts with Kerberos will fail
processing client list

Program received signal SIGSEGV, Segmentation fault.
authunix_refresh (auth=0xf86af60) at auth_unix.c:289
289       if (auth->ah_cred.oa_base == au->au_origcred.oa_base)
(gdb) bt
#0  authunix_refresh (auth=0xf86af60) at auth_unix.c:289
#1  0x0f866e54 in ?? () from /lib/tls/libc.so.6
#2  0x0f866e54 in ?? () from /lib/tls/libc.so.6
Previous frame identical to this frame (corrupt stack?)
(gdb) quit                   
--- gdb session ---

Just holler if you need any additional info..
Comment 1 Steve Dickson 2007-04-21 08:29:46 EDT
I believe this is fixed with a patch from bz189900 which means
nfs-utils-1.0.6-79.EL4 slove this problem. Please verfiy. 
Comment 2 Jakub Hrozek 2007-05-28 16:34:49 EDT
Sorry for the late reply.

Yes, I tried to reproduce this problem with the latest nfs-utils 
(nfs-utils-1.0.6-80) and it seems it's fixed.
Comment 3 Steve Dickson 2007-06-21 19:26:53 EDT
*** Bug 241106 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.