Bug 235126 - G965 Modesetting (intel) Branch problems
G965 Modesetting (intel) Branch problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 16:32 EDT by danwaineo
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 16:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (587 bytes, application/octet-stream)
2007-04-04 13:42 EDT, danwaineo
no flags Details
Xorg.0.log (67.03 KB, text/plain)
2007-04-04 13:43 EDT, danwaineo
no flags Details
New Xorg.0.log with fx86-video-intel, xserver, mesa, drm, etc. from git (55.73 KB, text/plain)
2007-04-06 11:00 EDT, danwaineo
no flags Details

  None (edit)
Description danwaineo 2007-04-03 16:32:09 EDT
I have a DG965OT motherboard with G965 graphics and an ADD2 card.  I'm
displaying on a Viewsonic 2750w LCD tv.  In fedora core 6, the intel driver
didn't work at all.  In Core 7 Test 3 live CD, I get an option for 1280x720x60
which I believe is the native resolution.  The problem is that there is a 1/2"
bar on the left side of the screen that looks blury.  If I send the mouse all
the way to the right, I can see the white movement on the left.  It's the mouse
cursor heavily distorted.

I'm also getting overscan, but I suppose that is expected on a LCD TV.  My old
resolution of 1280x1024 perfectly filled the screen, but wasn't a wide screen
resolution so things were distorted.

This is the only error message:

(EE) intel(0): Unable to write to SDVOCTRL_E for SDVOB Slave 0x70

That message is repeated throughout Xorg.0.log about thirty times.

Thanks for your help!


Release Date: 14 March 2007
Comment 1 danwaineo 2007-04-03 18:47:32 EDT
Interesting...

Everything seems to work perfectly if I use the VGA port.  I have 1280x720x60
with no artifacts or overscan.  It appears the problem is just with the DVI ADD2
card.  I'm using a wintec ADD2 card:  WINTEC 35111141-R

I purchased it from newegg:
http://www.newegg.com/Product/Product.aspx?Item=N82E16815133001
Comment 2 Matěj Cepl 2007-04-04 12:39:25 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 danwaineo 2007-04-04 13:42:00 EDT
Created attachment 151681 [details]
xorg.conf
Comment 4 danwaineo 2007-04-04 13:43:38 EDT
Created attachment 151683 [details]
Xorg.0.log
Comment 5 danwaineo 2007-04-04 13:47:40 EDT
This xorg.conf is created after I pick the intel driver using the display
settings GUI.  If I have no xorg.conf, then the created file uses the i810
driver which doesn't do modesetting.  So id don't think attaching the log will
be helpful for that case.
Comment 6 danwaineo 2007-04-06 03:42:01 EDT
I tried installing the new xserver and xf86-video-intel driver from git (plus a
bunch of other packages trying to get them to compile.  I finally got it working
but am getting the same visual errors.

Should I be creating an xorg bug report?

 
Comment 7 Matěj Cepl 2007-04-06 05:12:48 EDT
Could we get updated /var/log/Xorg.*.log and /etc/X11/xorg.conf (if different
from the previous one), please?
Comment 8 danwaineo 2007-04-06 11:00:36 EDT
Created attachment 151873 [details]
New Xorg.0.log with fx86-video-intel, xserver, mesa, drm, etc. from git

Added new Xorg.0.log

I didn't use a Xorg.conf file this time.  Things of note:


I think that was the same error as before.
(EE) intel(0): Unable to write to SDVOCTRL_E for SDVOB Slave 0x70.

Not sure if this is a problem or not.  Maybe something I screwed up when trying
to install:
(II) Module fbdevhw: vendor="X.Org Foundation"
	compiled for 7.1.99.2, module version = 0.0.2
	ABI class: X.Org Video Driver, version 2.0
(EE) open /dev/fb0: No such file or directory

I think I misconfigured something here, since the end of the log file fills
with this:
[dbus] couldn't take over org.x.config: org.freedesktop.DBus.Error.AccessDenied
(Connection ":1.26" is not allowed to own the service "org.x.config.display0"
due to security policies in the configuration file)

Other things: 
Compiz doesn't work any more.  I'm guessing I need a new version now.  Glxgears
works ok.  Sample compiz errors:
compiz: pixmap 0x3e000c9 can't be bound to texture
compiz: Couldn't bind redirected window 0xe0002f to texture

Other then that I have to manually startx now after removing /tmp/.X0-lock

Let me know if I can get you anything else.
Comment 9 danwaineo 2007-04-06 11:38:25 EDT
One other thing.  I was trying to run the Abat test and is says that DRI is
disabled.

$  glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No

I don't see anything about this though in Xorg.0.log
Comment 10 danwaineo 2007-04-06 13:03:54 EDT
I think glxinfo is lying.  Ppracer and other games are working.
Comment 11 Matthew Miller 2007-04-10 12:31:45 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 12 danwaineo 2007-04-13 16:32:38 EDT
Sorry, the problem was caused by an overscan setting on my lcd tv.  Everything
looks great now.  I'm running FC7 Devel.  You can close this one - it was just
my own dumb error.

Note You need to log in before you can comment on or make changes to this bug.