Bug 235157 - On-chip RMX mode cause video corrupt on IBM server
On-chip RMX mode cause video corrupt on IBM server
Status: CLOSED DUPLICATE of bug 235156
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 23:39 EDT by LisaWu
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 09:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
while validate DFP modes, we matching modes from EDID info by default (631 bytes, patch)
2007-04-03 23:39 EDT, LisaWu
no flags Details | Diff

  None (edit)
Description LisaWu 2007-04-03 23:39:34 EDT
Description of problem:
when install RHEL5-BETA2 on IBM Lewis server, video on local monitor is in 
poor quality, and there is no video output on remote control.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.3-1.el5.rpm

How reproducible:
always

Steps to Reproduce:
1.connect a monitor to server
2.log in to the remote control 
3.install rhel5-beta2 and start X-windows
  
Expected results:
following modes on both local monitor and remote control should be OK.
vesa mode: 1024x768@75hz, 70hz,60hz
           800x600@75hz,72hz,60hz
           
Actual results:
None of the above modes are OK.

Additional info:
on-chip RMX mode is only enabled when the driver thinks it’s driving a digital 
panel which will cause poor quality on CRT. This is also an old day’s radeon 
driver preference that probably shouldn’t be used any more because almost all 
modern TMDS panels have internal scaler which usually can result in better 
quality than our internal RMX.
in our case, radeon driver use RMX modes for remote video by default, however, 
the stretched RMX modes can't be well supported. 
To fix this bug, we can change digital pannel mode validation routine not to 
use RMX mode by default, but validate modes by matching modes from EDID info 
instead.
Comment 1 LisaWu 2007-04-03 23:39:34 EDT
Created attachment 151642 [details]
while validate DFP modes, we matching modes from EDID info by default
Comment 2 LisaWu 2007-04-03 23:55:33 EDT
duplicate of #235156, sorry for the inconvenience
please close this one.
Comment 3 Matěj Cepl 2007-08-17 09:14:42 EDT

*** This bug has been marked as a duplicate of 235156 ***

Note You need to log in before you can comment on or make changes to this bug.