Bug 235209 - Remove the rhnLocation and rhnPackageLocation tables
Remove the rhnLocation and rhnPackageLocation tables
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
John Sanda
:
Depends On:
Blocks: 239809
  Show dependency treegraph
 
Reported: 2007-04-04 11:20 EDT by James Bowes
Modified: 2013-01-10 04:52 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 14:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2007-04-04 11:20:30 EDT
These two tables (and their associated grants and synonyms) are empty and
unused; they should be removed.
Comment 1 James Bowes 2007-06-19 10:33:49 EDT
There are two parts to testing:
- Look in the db and ensure that these tables are gone.
- Make sure that the code which used these tables still works
  * The key parts to this are downloading rpms, so for best coverage:
    + register a rhel 4 system, install rpms with up2date
    + register a rhel 5 system, install rpms with yum
Comment 2 John Sanda 2007-06-20 14:33:05 EDT
There are references to both rhnLocation and rhnPackageLocation in the java code
base. ChannelManager.listDownloadImages calls a query that references
rhnLocation. rhnPackageLocation is referenced in Package_queries.xml, but it
looks like it may be dead code.

On the perl side, looks like rhnLocation is referenced in
web/modules/rhn/RHN/DB/DataSource/xml/Channel_queries.xml. Not sure though if
and where it is used.
Comment 3 James Bowes 2007-06-20 16:18:31 EDT
All of it was dead code. awesome.
Comment 4 John Sanda 2007-06-21 17:00:24 EDT
Neither rhnLocation nor rhnPackageLocation exist in the rhn database schemas in
webqa.

I was able to install rpms on a rhel 5 system using yum.
I was able to install rpms on a rhel 4 system using up2date.

Grepping through the code base....
* Did not find any references to rhnLocation or rhnPackageLocation in the java tree.
* I found a few references in the schema tree. Just looks like table, synonym,
and grant declarations. They should not cause any problems, but we probably
ought to remove them from the source tree.
* Did not find any references to rhnLocation or rhnPackageLocation in the web tree.
Comment 5 John Sanda 2007-07-23 14:52:01 EDT
Verified in stage.
Comment 6 James Bowes 2007-07-25 11:18:45 EDT
rhn502 released.

Note You need to log in before you can comment on or make changes to this bug.