Bug 23521 - mouseconfig misdectects mouse, offers no escape
mouseconfig misdectects mouse, offers no escape
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: mouseconfig (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-07 06:03 EST by Andrew Bartlett
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2001-01-07 06:03:01 EST
Mouseconfig (and kudzu) don't correctly detect my old, bland microsoft
serial mouse, when used with kernel 2.4.  While this is annoying,
mouseconfig cannot corectly descirbe this phantom PS/2 mouse, so offers a
choice.  This list includes serial mice, but mouseconfig does not register
that I chose a serial mouse, and continues to use psaux as the device.

(I presume the phantom psaux port is a kernel, not a kudzu problem - and I
suspect this bug is going to be hard to test, as it needs a wonky ps/2
mouse port to show up).  Then again, you might not want to fix it - I just
have to re-run mouseconfig manualy, and the current setup is more
idiot-proof.
Comment 1 Andrew Bartlett 2001-01-07 06:09:36 EST
On further testing - this serial mouse is really shot.  I was wondering why I
cannot get the magic middle button (ie both togeather) to work, but now find the
pressing the right button on its own does the job.  No wonder it wasn't detected
very well (soon to be retired back to the 'bits and peices bin' it came from). 
The other issues might still be worth resolving though, and the phantom ps/2
port came from somewhere....
Comment 2 Robert Tiffany 2001-02-21 11:34:41 EST
Same Problem experienced here I am using a generic 3 button serial mouse ms 
compat. mousecfg defaults to generic 2 button ps/2 device, I choose the correct 
3 button serial device and have to continue through the installer using the 
keyboard for navigation.  Upon reboot after installation is complete the system 
boots and the correct mouse operates fine.
Comment 3 Brent Fox 2002-10-10 14:15:13 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 4 Red Hat Bugzilla 2006-02-21 13:47:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.