Bug 23530 - RFE: start ntpd earlier
RFE: start ntpd earlier
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ntp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Wil Harris
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-07 06:48 EST by Michael Redinger
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 15:14:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-01-07 06:48:21 EST
Could ntpd be started a bit earlier? This would 
guarantee correct time for more init scripts/programs.
I'd suggest 
# chkconfig: - 26 74
instead of
# chkconfig: - 55 10
(this would still guarantee that ntpd is found - this
config would mean starting it right after and stopping
it just before netfs.)
Comment 1 Daniel Roesen 2001-01-08 13:55:20 EST
ntpd usually takes some minutes before correcting system time, so moving it in
the bootup sequence doesn't make any difference.
Comment 2 Jeff Johnson 2001-01-08 14:13:20 EST
Not true. ntpdate sets the time efficiently, synchronization an PLL lock is what
takes 5+ minutes.
All dependent on configuration, which we cannot ship with enabled by default,
YMMV.
Comment 3 Daniel Roesen 2001-01-08 14:16:26 EST
Yes, ntpdate does immediately set system time. But ntpd (which we are talking
about) does not.

Am I screwed somewhere? ;>
Comment 4 Michael Redinger 2001-01-08 14:24:14 EST
If /etc/ntp/step-tickers is used, ntpdate is called immediately at 
ntpd startup (see the startup script). No delay here (hm, don't
think this is documented; should be, I suppose ...). I used to 
call ntpdate in  rc.local until I found out that this is provided in the
ntpd startup script ...
Comment 5 Jeff Johnson 2001-01-08 14:32:23 EST
What's needed is to set the system accurately and early as possible,  not  to
synch with
a server. FWIW, ntpd guarantees monotonicity (i.e. time never goes backward),
which
ntpdate does not, but that's another reason to run ntpdate if possible as early
as possible.
Comment 6 Michael Redinger 2001-01-08 14:38:48 EST
:) Seems to be perfectly ok with my request (yes, some time ago
our time server admin who's using one of my Linux servers told
me about all that stuff ...).
Starting ntpd early means starting ntpdate early, right?
Comment 7 Jeff Johnson 2001-01-08 15:14:11 EST
Yup. Howvere, the real problem is that we can't distribute with a pre-configured
step-ticker
(hate the name, <shrug>) server.
Comment 8 Preston Brown 2001-02-05 15:41:30 EST
changed in ntp 4.0.99k-7 and later.

Note You need to log in before you can comment on or make changes to this bug.