Bug 235311 - section 18.7.6 where it talks about SELINUX with XEN
section 18.7.6 where it talks about SELINUX with XEN
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Don Domingo
Michael Hideo
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 20:00 EDT by Michael Hideo
Modified: 2013-01-10 16:45 EST (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2007-0611
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:43:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix to Screenshot (13.21 KB, image/png)
2007-04-04 20:12 EDT, Michael Hideo
no flags Details

  None (edit)
Description Michael Hideo 2007-04-04 20:00:31 EDT
Rob:

I'm pasting a bit of the dialog I had with tech support regarding my
last Xen issue.  I'd like to follow up with you, as well.  This is an
instance where redhat's documentation is incomplete, and following the
given example would not work.  Can this please be fixed?

- -- Pat

03-APR-2007 11:21:31     Mayo Foundation

May I ask for directions on how to adjust selinux appropriately?

I note that the Redhat Virtualization Guide, section 18.7.6, in the
screenshot there, image 18.11, shows using a disk path
"/xen/xen-guest", obviously not "/var/lib/xen".

If this is correct about selinux, this example wouldn't work either.

Can the documentation please be adjusted to include the appropriate
selinux directions?

Thanks,
- -- Pat

03-APR-2007 11:21:31     Mayo Foundation
Status changes from "Waiting on Customer" to "Waiting on Red Hat".
03-APR-2007 02:08:36     Persai, Rohit
Update:

It seems that the problem is related to "selinux" policies.

By default, the path for the virtual disk is set to "/var/lib/xen",
this is in accordance with "selinux" policies.
If you have "selinux" enabled and want to specify custom path for the
virtual disk then you need to change selinux policies accordingly.

Regards,
Rohit.
Comment 1 Michael Hideo 2007-04-04 20:12:13 EDT
Created attachment 151721 [details]
Fix to Screenshot

[mhideo@mhideo images]$ cvs commit -m"fixing screenshot to fix BZ#235311"
virt-manager.5.png
Fixed in DocBot

https://engineering.redhat.com/docbot/en-US/RHEL-5.0.0/html/Virtualization/images/virt-manager.5.png


Please advise if this is only a screenshot fix.

**** Access allowed: mhideo is in ACL for
Documentation/Virtualization/en-US/images.
Checking in virt-manager.5.png;
/cvs/ecs/Documentation/Virtualization/en-US/images/virt-manager.5.png,v  <-- 
virt-manager.5.png
new revision: 1.3; previous revision: 1.2
done
Comment 2 Michael Hideo 2007-04-04 22:08:44 EDT
Rohit,

Please confirm if the following amendment clarifies the procedure for the reader:

https://engineering.redhat.com/docbot/en-US/RHEL-5.0.0/html/Virtualization/virt-install-wizard.html

"This example installs a virtual system within a file.

The default SELinux policy permits xen disk images to reside in the /var/lib/xen
. If you have SELinux enabled and want to specify a custom path for the virtual
disk then you need to change SELinux policies accordingly "
Comment 3 Michael Hideo 2007-06-06 00:50:17 EDT
Adding 'cc ecs-dev-list@redhat.com for team coverage
Comment 11 errata-xmlrpc 2007-11-07 11:43:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0611.html

Note You need to log in before you can comment on or make changes to this bug.