Bug 235327 - FC6 -> FC7t3 upgrade can lead to incorrect grub config
FC6 -> FC7t3 upgrade can lead to incorrect grub config
Status: CLOSED DUPLICATE of bug 229704
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 02:38 EDT by cam
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 10:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cam 2007-04-05 02:38:54 EDT
Description of problem:

I tried to upgrade a FC6 machine to FC7t3 using the DVD. Anaconda didn't find
the grub config. I asked it to make a new installation of grub and the resulting
menu.lst had incorrect numbers for the HD, eg. (1,2) instead of (0,2).

The symptoms were: grub menu behaved erratically (unable to edit boot commands);
grub wasn't able to load a kernel, and the machine reset continually.


Version-Release number of selected component (if applicable):
FC7t3 anaconda
Dell Inspiron 6000 (ICH6M SATA Controller, /dev/scd0, /dev/sda)

How reproducible:
Haven't tried to reproduce it, but expect it will reproduce easily.

Steps to Reproduce:
1. FC6 machine with SATA disk as above
2. Upgrade from FC7t3 DVD
3. Observe non booting and grub misbehaviour
  
Actual results:
non booting and grub misbehaviour

Expected results:
successful upgrade, booting and grub functional

Fix:
I used the rescue disc to boot and edited the /boot/grub/menu.lst to (0,x)
instead of (1,x) throughout, and the FC7t3 install was fine. 


Additional info:

The edited (working) grub.comf. Note the comment still refers to root (hd1,2):

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd1,2)
#          kernel /vmlinuz-version ro root=/dev/sdb7
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.20-1.3040.fc7)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.3040.fc7 ro root=LABEL=/1 rhgb quiet
        initrd /initrd-2.6.20-1.3040.fc7.img
title Fedora (2.6.20-1.3023.fc7)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.3023.fc7 ro root=LABEL=/1 rhgb quiet
        initrd /initrd-2.6.20-1.3023.fc7.img
title Fedora-base (2.6.20-1.2933.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.2933.fc6 ro root=/dev/sdb7 rhgb quiet
title Other
        rootnoverify (hd0,0)
        chainloader +1
Comment 1 Jeremy Katz 2007-04-09 11:34:34 EDT
And what were the contents of /boot/grub/device.map?
Comment 2 cam 2007-04-09 12:49:11 EDT
# cat /boot/grub/device.map
(fd0)   /dev/fd0
(hd0)   /dev/sda
(hd1)   /dev/sdb
Comment 3 Chris Lumens 2007-04-16 10:18:05 EDT

*** This bug has been marked as a duplicate of 229704 ***

Note You need to log in before you can comment on or make changes to this bug.