Bug 235342 - Default charset should be UTF-8
Default charset should be UTF-8
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 06:14 EDT by Jan Kratochvil
Modified: 2007-12-11 06:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 06:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dialog which should never be seen by a user. (9.86 KB, image/png)
2007-04-05 06:14 EDT, Jan Kratochvil
no flags Details
F8 thunderbird-2.0.0.9-1.fc8.x86_64 default settings screenshot. (45.53 KB, image/png)
2007-12-10 05:06 EST, Jan Kratochvil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 224391 None None None Never

  None (edit)
Description Jan Kratochvil 2007-04-05 06:14:17 EDT
Description of problem:
It is proven the non-technical people cannot send non-ASCII e-mails by Thunderbird.
The default character set is ISO-8859-2 while it should be UTF-8 nowadays.

Version-Release number of selected component (if applicable):
thunderbird-1.5.0.10-1.fc6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Thunderbird on a pure FC6 installation.
2. Write an e-mail with letters ěščřžýáíéůúĚŠČŘŽÝÁÍÉŮÚ.

Actual results:
It will ask you with the attached dialog. After "Send anyway" you get:
Content-Type: text/plain; charset=windows-1252; format=flowed
e(šc(r(žýíéE(ŠC(R(ŽÝÁÍÉu*úU*Ú
(even no ISO-8859-1, interesting)

Expected results:
I should get either "iso-8859-2" or "utf-8" without any user intervention.
And I should get back the original characters I wrote.

Additional info:
Mutt MUA has a nice feature:
  set send_charset="us-ascii:iso-2022-jp:utf-8"
Where it tries to fit the written mail body into each listed charset from the
minimal one to the full (utf-8) one.  It would be a FEAT, though.
Comment 1 Jan Kratochvil 2007-04-05 06:14:17 EDT
Created attachment 151749 [details]
Dialog which should never be seen by a user.
Comment 4 Matěj Cepl 2007-12-10 04:23:13 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 5 Jan Kratochvil 2007-12-10 05:06:55 EST
Created attachment 282571 [details]
F8 thunderbird-2.0.0.9-1.fc8.x86_64 default settings screenshot.
Comment 6 Jan Kratochvil 2007-12-10 05:07:40 EST
The Bug is still valid for: thunderbird-2.0.0.9-1.fc8.x86_64

Note You need to log in before you can comment on or make changes to this bug.