Bug 235374 - Update of iputils starts rdisc, breaking connectivity
Update of iputils starts rdisc, breaking connectivity
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Bacovsky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 10:33 EDT by Chris Ricker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: iputils-20070202-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 11:01:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2007-04-05 10:33:45 EDT
fc6

did a yum update, which upgraded to iputils 20070202-1.fc6

I didn't have rdisc running, and had it disabled in all runlevels

the upgrade started it, which killed my network connectivity

Looks like a script issue in the packaging
Comment 1 Martin Bacovsky 2007-04-06 07:00:33 EDT
This issue should be fixed in iputils-20070202-2.fc6
Comment 2 Chris Ricker 2007-04-16 12:01:28 EDT
It's not fixed

[root@slartibartfast ~]# chkconfig --list rdisc
rdisc           0:off   1:off   2:off   3:off   4:off   5:off   6:off
[root@slartibartfast ~]# 

rdisc isn't running

I do a yum update, which takes me from

iputils-20070202-1.fc6

to

iputils-20070202-3.fc6

rdisc gets started, with resultant network breakage....
Comment 3 Martin Bacovsky 2007-08-06 11:01:32 EDT
During update process rpm first install new package and then remove the old one.
IFAIK the last script executed during the update (in this case) is faulty
%postun from iputils-20070202-1.fc6. 

The only way (i know of) how to avoid restarting rdisc daemon during update is
to  update iputils with rpm 
# rpm -Uvh --nopostun <path to>/iputils-20070202-3.fc6.rpm

Update from version iputils-20070202-3 and above should work as required.

Note You need to log in before you can comment on or make changes to this bug.