This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 235389 - Hang on exit
Hang on exit
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rssowl (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 11:15 EDT by Robin Green
Modified: 2008-01-03 14:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 14:21:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2007-04-05 11:15:08 EDT
Description of problem:
rssowl hangs after you close the main window. It looks like it is not managing
to save its prefs (they used to be in files called .rssowl/user.xml and
.rssowl/.user).

Version-Release number of selected component (if applicable):
rssowl-1.2.3-3.fc7

How reproducible:
Always

Steps to Reproduce:
1. Remove $HOME/.rssowl directory
2. Start rssowl
3. File->Quit
  
Actual results:
shell prompt does not reappear

Expected results:
shell prompt should reappear

Additional info:
I can't debug this with gdb. If I press CTRL+C in gdb when it hangs, I get an
unhelpful stacktrace:

Reading in symbols for pthread_mutex_unlock.c...done.
#0  0x00002aaaab1ab0d6 in *__GI___poll (fds=0x2aab007195c0, nfds=7, timeout=-1)
at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003c59a2fe7e in ?? ()
#2  0x00002aab00027270 in ?? ()
#3  0x0000000100000001 in ?? ()
Reading in symbols for mtrace.c...done.
#4  0x00002aaaaaccf880 in strcat () from /lib64/libpthread.so.0
#5  0x000000000000108b in ?? ()
#6  0x7fffffffffffffff in ?? ()
#7  0x00002aab00599910 in ?? ()
#8  0x0000000000000000 in ?? ()

and gdb has an internal error if I then try to do "info threads".
Comment 1 Anthony Green 2008-01-03 14:21:20 EST
RSSOwl is no longer part of Fedora due to dependency licensing problems.  I'm
closing this with WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.