Bug 235418 - NetworkManager has problems intermittantly connection to WPA Personal network
NetworkManager has problems intermittantly connection to WPA Personal network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 13:07 EDT by Norm Murray
Modified: 2008-10-20 10:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 10:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The output in var log messages when the applet does not connect (3.41 KB, application/octet-stream)
2007-04-05 13:08 EDT, Wade Mealing
no flags Details
Output of var log messages when network manager does connect (5.50 KB, application/octet-stream)
2007-04-05 13:10 EDT, Wade Mealing
no flags Details
And.. it still happens (10.60 KB, application/octet-stream)
2007-10-25 12:23 EDT, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2007-04-05 13:07:19 EDT
Description of problem:

Networkmanager starts, wireless card comes up, selecting a network from the list
(Or when network manager auto-detects my home network, then autoconnects),
NetworkManager will fail to continue the connection.

Version-Release number of selected component (if applicable):

NetworkManager-glib-0.6.5-0.6.svn2474.fc7
NetworkManager-0.6.5-0.6.svn2474.fc7
NetworkManager-gnome-0.6.5-0.6.svn2474.fc7

How reproducible:

1/3 times, but usually when I'm already frustrated after a long days work.

Steps to Reproduce:
1. Boot laptop, log into gnome.
2. See nm-applet do spinny thing
3. tail the var log messages, notice it didnt get a dhcp lease, frown.
  
Actual results:

nm-applet does not connect to my wireless 

Expected results:

nm to connect to my wireless server so I can go about my life.

Additional info:

It seems whenever it fails, I see the log in the messages..

Apr  6 02:43:36  localhost NetworkManager: <info>  Old device 'ath0' activating,
won't change. 

However when it works, I get

Apr  6 02:45:54  localhost kernel: ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready

var log messages sections to be attached.
Comment 1 Wade Mealing 2007-04-05 13:08:07 EDT
Created attachment 151783 [details]
The output in var log messages when the applet does not connect
Comment 2 Wade Mealing 2007-04-05 13:10:28 EDT
Created attachment 151785 [details]
Output of var log messages when network manager does connect
Comment 4 Doncho N. Gunchev 2007-05-03 15:53:49 EDT
This happens for me about 1/20 times, but gets better, mostly when the signal is
weaker. Does it help if you stop NM; rmmod (your_wls_card_module_here); insmod
(your...) and then restart NM? That works for me...

btw: I used only wpa_supplicant (edit the conf file and start) the first time I
got connected to my AP and it never failed. Maybe NM is not waiting enough at
some point and should certainly not clear my passphrase every time - ask yes,
but fill in the old one. I use the knetworkmanager applet and wpa2 if that matters.
Comment 5 Wade Mealing 2007-06-12 11:10:44 EDT
It usually does, but i cant get it to work properly.

This seems to work though.

#!/bin/bash

service NetworkManger stop
/usr/sbin/wpa_supplicant -dd -Dmadwifi -c/etc/wpa_supplicant/wpa_supplicant.conf
-iath0
/sbin/dhclient ath0


wpa_supplicant is of course populated with the correct values.
Comment 6 Wade Mealing 2007-10-25 11:53:41 EDT
Still happening in F8T3 and current rawhide.

Comment 7 Wade Mealing 2007-10-25 12:23:37 EDT
Created attachment 237581 [details]
And.. it still happens

Updated error messages.. this still works if i set it up manually.
Comment 8 Wade Mealing 2007-10-25 12:42:05 EDT
ok,

set /etc/sysconfig/wpa_supplicant up to look like this
INTERFACES="-i wlan0 "
DRIVERS="-D madwifi -dd"


Start the service, have it start on boot.. make this your wpa_supplicant startup
params, now it works.  Till we meet again networkmanager
Comment 9 Tim Lauridsen 2007-10-26 05:12:38 EDT
I have the same problems in current rawhide, NetworkManager can't connect to my
WPA AP at home.
I works if i use

service NetworkManger stop
/usr/sbin/wpa_supplicant -dd -Dmadwifi -c/etc/wpa_supplicant/wpa_supplicant.conf
-iath0 -B
/sbin/dhclient ath0

I will try modifying /etc/sysconfig/wpa_supplicant when i get home.
why wlan0, shouldn't it be ??
INTERFACES="-i ath0 "

Comment 10 Tim Lauridsen 2007-10-31 04:45:08 EDT
Thanks !!!!.

All my problems with NetworkManager & wpa_supplicant is solved in Rawhide.
NetworkManager connects without any problems to my WPA2 access point on my
Thinkpad T60 (Madwifi driver)

The is a problem connecting after suspend/resume, i have to 
modprobe -r ath_pci
modprobe ath_pci

Then it is working again. (I don't think this issue have any thing todo with NM)

Comment 12 Bug Zapper 2008-05-13 22:44:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Dan Williams 2008-10-20 10:59:33 EDT
Ok, fixed in current release then.

Note You need to log in before you can comment on or make changes to this bug.