Bug 23545 - RFE: use LILO "compact" option for Adaptec SCSI chipset boots.
Summary: RFE: use LILO "compact" option for Adaptec SCSI chipset boots.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-07 18:37 UTC by Sam Varshavchik
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 19:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Varshavchik 2001-01-07 18:37:05 UTC
Without compact, LILO loads the kernel and initrd with one BIOS call per
each disk block.  It seems that certain BIOSes impose a pretty heavy
penalty per BIOS call, when booting.  It can literally take a minute, or
more, for the kernel and initrd to load.  Meanwhile, LILO prints a dot at a
leisurely pace of one every other second, or so.

Most of the culprits seem to be SCSI controller onboard BIOSes.  A
Supermicro P6DGU motherboard is rather slow, without the "compact" option,
but it's not too bad.  An Asus P2DS motherboard is pretty bad, when booting
off a SCSI disk (an IDE boot seems to be reasonable).  Using the "compact"
option with LILO cuts down the kernel load time from about 45 seconds to
less than a second.  Same thing with an ABIT BP6 motherboard. It takes
about a minute to load the kernel image off the SCSI disk without the
compact option.  Running "lilo -v -v" with the compact option shows that
almost 1500 BIOS calls have been eliminated, resulting in an instant boot -
less than a second to load both the kernel image and initrd.

I think the installer should write the "compact" option to lilo.conf when
the boot disk is a SCSI disk hooked up via an Adaptec chipset.  I've never
had any problems whatsoever with the compact option with Adaptec chipset
BIOSes.

Comment 1 Michael Fulbright 2001-01-09 21:30:14 UTC
Marked as a future feature request.


Note You need to log in before you can comment on or make changes to this bug.