Bug 235476 - Port setuputil onto Solaris
Port setuputil onto Solaris
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.0.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-04-05 20:54 EDT by Noriko Hosoi
Modified: 2015-12-07 11:47 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:47:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cvs diffs configure.ac m4/{nspr,nss,mozldap}.m4 (1.58 KB, patch)
2007-04-06 16:21 EDT, Noriko Hosoi
no flags Details | Diff
cvs commit message (918 bytes, text/plain)
2007-04-09 18:15 EDT, Noriko Hosoi
no flags Details

  None (edit)
Description Noriko Hosoi 2007-04-05 20:54:40 EDT
Description of problem:
This bug is a follow up of "234893: Build SetupUtil with autotools"
Comment 1 Noriko Hosoi 2007-04-06 16:21:13 EDT
Created attachment 151895 [details]
cvs diffs configure.ac m4/{nspr,nss,mozldap}.m4

Files:
  configure.ac
  m4/mozldap.m4
  m4/nspr.m4
  m4/nss.m4

Changes:
1) Solaris and HP-UX needs -DSOLARIS and -DHPUX in the compile option,
respectively
2) pkg-config returns 2 library paths for dirsec-nspr and mozldap6 on Solaris
as follows:
    $ pkg-config --libs-only-L dirsec-nspr
    -L/usr/lib/sparcv9/dirsec -L/usr/lib/sparcv9
    $  pkg-config --libs-only-L mozldap6
    -L/usr/lib/sparcv9/dirsec -L/usr/lib/sparcv9
   sed commands in m4/*.m4 did not support the case.
Comment 2 Nathan Kinder 2007-04-09 18:10:55 EDT
Looks good!
Comment 3 Noriko Hosoi 2007-04-09 18:15:45 EDT
Created attachment 152069 [details]
cvs commit message

Reviewed by Nathan (Thank you!!)

Checked in into HEAD.
Comment 4 Nathan Kinder 2007-12-17 14:08:58 EST
Setuputil has been ported to Solaris, but we have since replaced it with some
Perl setup modules.  Marking this bug as verified since the porting work is
complete.


Note You need to log in before you can comment on or make changes to this bug.