Bug 235483 - ata_piix booting fails
ata_piix booting fails
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2007-04-06 00:59 EDT by vikram goyal
Modified: 2009-12-14 15:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-26 19:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (26.33 KB, application/octet-stream)
2007-04-06 00:59 EDT, vikram goyal
no flags Details

  None (edit)
Description vikram goyal 2007-04-06 00:59:03 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.On booting sytem freezes after loading ata_piix
Actual results:

Expected results:

Additional info:
Comment 1 vikram goyal 2007-04-06 00:59:03 EDT
Created attachment 151824 [details]
dmesg output
Comment 2 vikram goyal 2007-04-06 01:06:56 EDT
normal kernel boots ok. The problem lies only in xen version.
Since I can't save the error message, I have attached dmesg of normal kernel.
The booting stops somewhere after this line in current attached dmesg file:

ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:00:1f.2 to 64 -> [Please see: This
message does not shows]
ata1: SATA max UDMA/133 cmd 0xEC00 ctl 0xE802 bmdma 0xDC00 irq 16
ata2: SATA max UDMA/133 cmd 0xE400 ctl 0xE002 bmdma 0xDC08 irq 16
scsi0 : ata_piix -> [Please see: This message does not shows]
usb 2-1: new low speed USB device using uhci_hcd and address 3
[ Shows error here and reboots after sometime with some message with ata module
or something ]

with a message: retrying in 5 seconds or so. After two or three retries the
machine reboots.
Comment 3 vikram goyal 2007-04-06 02:43:36 EDT
I was able to note down the error messages:

ata 1.00: qc timeout (cmd 0xef)
ata 1.00: failed to set xfermode (err_mask-0x4)
ata 1.00: limiting speed to PIO0
ata 1.00: failed to recover some devices, retrying in 5 secs

after this kernel panic and reboot occurs.

Also the lines which I have marked as
-> [Please see: This message does not shows] are wrong. These lines do show.
It was goof up on my side.

Comment 4 Red Hat Bugzilla 2007-07-24 21:40:13 EDT
change QA contact
Comment 5 Chris Lalancette 2008-02-26 19:03:37 EST
This report targets FC6, which is now end-of-life.

Please re-test against Fedora 7 or later, and if the issue persists, open a new bug.


Note You need to log in before you can comment on or make changes to this bug.