Bug 235514 - Fonts garbled when connecting to Windows XP, Windows Server 2003
Fonts garbled when connecting to Windows XP, Windows Server 2003
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-06 11:41 EDT by Jonathan Kamens
Modified: 2013-03-05 22:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 08:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-04-06 11:41:11 EDT
When I use rdesktop (current devel as well as FC6) to connect to a Windows XP or
Windows Server 2003 machine, lots of my fonts on the other end are garbled --
weird characters, blank spaces, or boxes display instead of the correct font
characters.

When I connect to the same machines using the Microsoft terminal services client
from inside VMware, everything is fine, so I don't think the problem is at the
other end.

Because I don't believe this started happening until recently, and because it
happens with both the current (1.5) and old (1.4) version of rdesktop, I am
wondering if perhaps the problem is not rdesktop but rather is the X server. 
I'm using current Fedora Devel versions of all the X RPMs, with the Via
unichrome driver.
Comment 1 Jonathan Kamens 2007-04-16 08:28:59 EDT
Something in the Rawhide packages current as of yesterday has fixed this issue.
 At least, I can no long reproduce it.  I'll reopen if it comes up again.

Note You need to log in before you can comment on or make changes to this bug.