Bug 235522 - Intermittent boot halt (stop freeze crash) around Probing PCI hardware
Intermittent boot halt (stop freeze crash) around Probing PCI hardware
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-06 13:54 EDT by David Robertson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: Fedora7 Test4.
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-05 15:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmseg after good boot. (31.59 KB, text/plain)
2007-04-06 13:54 EDT, David Robertson
no flags Details
dmesg kernel 3045 into runlevel 3 (20.34 KB, application/octet-stream)
2007-04-06 23:08 EDT, David Robertson
no flags Details
messages log 3045 kernel level 3 then 3040 kernel level 5 (98.00 KB, application/octet-stream)
2007-04-06 23:11 EDT, David Robertson
no flags Details

  None (edit)
Description David Robertson 2007-04-06 13:54:34 EDT
Description of problem:

Boot process intermittently stops and locks up.  This happens on about 1 in 5
boots.  When it does not happen, the boot proceeds to the login prompt.  When it
does happen, it always happens in the same area of the boot messages, around
this snippet cut from dmseg (one of these lines are the last displayed):

ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PM: Adding info for No Bus:pci0000:00
Boot video device is 0000:00:05.0
0000:00:0d.0: cannot adjust BAR0 (not I/O)

The notebook must be manually turned off at this point.  I have tried various
boot options such as acpi=off, nosmp, and noapic; but no combination seems to
totally fix the problem.  The problem occurs slightly less often with this
kernel and happened much more often with the original kernel on the Fedora 7
Test 3 Live CD.  
 
This is on an HP dv6000z notebook with dual boot Windows Vista
It has a Phoenix BIOS with latest firmware to date; version F28
AMD Turion(TM) 64 X2 Dual-Core TL-56(1.8GHz/1MB) 
NVIDIA(R) GeForce(R) Go 6150 Video

Kernel: Linux version 2.6.20-1.3040.fc7



Steps to Reproduce:
1. turn on notebook.
2. fiddle with boot options at grub stage, if desired.
3. watch for above pasted boot messages 
  
Actual results:

when it gets to above pasted boot messages, boot stops on about 1 in 5 tries.


Expected results:

boot continues to login prompt.



Additional info:

Once (if) the boot process gets by the troublesome point, there doesnt seem to
be any ill effects there after.
Comment 1 David Robertson 2007-04-06 13:54:56 EDT
Created attachment 151892 [details]
dmseg after good boot.
Comment 2 David Robertson 2007-04-06 23:08:13 EDT
Created attachment 151904 [details]
dmesg kernel 3045 into runlevel 3
Comment 3 David Robertson 2007-04-06 23:11:09 EDT
Created attachment 151905 [details]
messages log 3045 kernel level 3 then 3040 kernel level 5
Comment 4 David Robertson 2007-04-06 23:12:39 EDT
Updated latest Fedora 7 changes as of 04/06/2007, which includes kernel
2.6.20-1.3045.fc7 and same problem persists.  With these updates, an additional
problem has been introduced in that even when the early boot process proceeds
forward with no crash, now it crashes when X starts up; every time.  Cannot boot
directly into runlevel 5, nor runlevel 3 then startx.  Same result- blank screen
and no response.  Going back to kernel 4050, used for this post.     
Comment 5 Matthew Miller 2007-04-10 11:54:19 EDT
Bulk message: Fedora 7 test bugs should be filed against "devel", not against
test1/2/3. This isn't obvious, I know. Moving this report so it isn't lost.
Comment 6 David Robertson 2007-04-10 19:57:01 EDT
Installed 3053 and then 3054 kernel and still crashing on boot at same area as
described above.  These 2 kernels also cause X to crash everytime.  Now using
kernel 3054 (Linux version 2.6.20-1.3054.fc7
(brewbuilder@hs20-bc1-7.build.redhat.com) (gcc version 4.1.2 20070403 (Red Hat
4.1.2-8)) #1 SMP Mon Apr 9 15:25:58 EDT 2007) and after fiddling around with
boot options; added noapic irqpoll and boots ok most of the time; x starts up,
and usb devices work ok.  Even with these boot options, the intermittent boot
halt STILL occurs at the boot area as described above.
Comment 7 David Robertson 2007-05-05 15:51:14 EDT
This is nolonger occurring with the latest test 4+ kernel:

Linux version 2.6.21-1.3116.fc7 

Seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.