Bug 235568 - When ran, it reports invalid syslog format strings
When ran, it reports invalid syslog format strings
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: epylog (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Konstantin Ryabitsev
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 08:03 EDT by Mike Chambers
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 17:04:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Email results when epylog is ran (582.78 KB, application/octet-stream)
2007-04-07 08:03 EDT, Mike Chambers
no flags Details
Epylog email results (582.78 KB, text/plain)
2007-04-07 08:10 EDT, Mike Chambers
no flags Details
My messages file (201.89 KB, text/plain)
2007-04-13 14:10 EDT, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2007-04-07 08:03:45 EDT
Description of problem:When epylog runs manually or automatically during
cron.daily, it gets various invalid syslog format strings in numerous files, all
of them I guess.


Version-Release number of selected component (if applicable):
epylog-1.0.3-5.fc7

How reproducible:Install epylog on FC7T3 or rawhide system and run it


Steps to Reproduce:
1.Install FC7T3 or rawhide
2.Install epylog
3./etc/cron.daily/./epylog.cron
  
Actual results:
Since it's too long, see attached file for results.

Expected results:Should be able to read the log files


Additional info:This is on an FC7T3+rawhide-updates system and current as of today.
Comment 1 Mike Chambers 2007-04-07 08:03:46 EDT
Created attachment 151912 [details]
Email results when epylog is ran
Comment 2 Mike Chambers 2007-04-07 08:10:22 EDT
Created attachment 151913 [details]
Epylog email results

Made this one a text file so you don't have to download it.
Comment 3 Mike Chambers 2007-04-07 08:13:06 EDT
Comment on attachment 151912 [details]
Email results when epylog is ran

See 2nd attachement, as this one comes up bin file.
Comment 4 Konstantin Ryabitsev 2007-04-13 12:46:47 EDT
Hmmm... Could you give me a small chunk of your /var/log/messages? It seems like
syslog string format has changed slightly.

Is this syslog or syslog-ng?
Comment 5 Konstantin Ryabitsev 2007-04-13 12:50:13 EDT
Created Epylog Trac ticket:
http://open.mcgill.ca/epylog/ticket/4
Comment 6 Mike Chambers 2007-04-13 14:10:39 EDT
Created attachment 152567 [details]
My messages file
Comment 7 Konstantin Ryabitsev 2007-04-13 17:04:08 EDT
Fixed upstream. Will be implemented in 1.0.4, which should be out in a few days.

Thanks!
Comment 8 Mike Chambers 2007-04-15 10:28:04 EDT
Maybe not that it matters now, but yesterday I had an actual html email this
time, but it was all jumbeled up and couldn't make out anything, and way too big
or something, almost froze computer.

But today I got my first actual good readable log file and looked just fine.  So
am thinking since your upgrade isn't out yet, maybe the syslog part fixed it (I
saw mentioned about the log files have two spaces instead of one)?

epylog-1.0.3-5.fc7
sysklogd-1.4.2-4.fc7

Note You need to log in before you can comment on or make changes to this bug.