Bug 235596 - esmtp should provide MTA
esmtp should provide MTA
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: esmtp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 13:48 EDT by Ville Skyttä
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-03 11:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-04-07 13:48:03 EDT
postfix, exim, and ssmtp have "Provides: MTA" (and sendmail should as well; will
report a bug), so I think esmtp should join the club and provide it too.
Comment 1 Robert Scheck 2007-04-07 13:50:47 EDT
MTA is a new virtual package or is it just to replace the other virtual package 
smtpdaemon? If last is true, then esmtp shouldn't provide MTA, otherwise it is 
okay...
Comment 2 Ville Skyttä 2007-04-07 14:04:01 EDT
MTA is MTA, SMTP daemon is a SMTP daemon, apples and oranges :)

In other words, "MTA" is not a replacement for "smtpdaemon".
Comment 3 Patrice Dumas 2007-04-07 17:47:36 EDT
I am not sure that esmtp should provide MTA, it is not a
MTA. ssmtp should also certainly not provide it. I think it
is the same for smtpdaemon. (ssmtp provides smtpdaemon, but I
think it is wrong). In my opinion send-only mta should only
provide /usr/sbin/sendmail. 

Maybe the meaning of virtual provides should be explained
somewhere. 

For MTA, it seems to me that it should imply a smtp server and
a mail delivery service, none of which is in esmtp.
Comment 4 Robert Scheck 2007-04-07 17:52:23 EDT
Well, esmtp from Fedora Extras Development doesn't provide smtpdaemon, but 
"ESMTP is a user configurable relay-only Mail Transfer Agent (MTA) with a
sendmail-compatible syntax." - IMHO enough to provide MTA.
Comment 5 Patrice Dumas 2007-04-07 18:15:44 EDT
It is not exactly true, esmtp isn't even relay-only, it is send-only.
esmtp isn't more a MTA than most of the MUA. Thunderbird, for example
is a MTA if esmtp is a MTA because it is able to send mail... 

From the definition in wikipedia, for example, esmtp is not a MTA. 
Moreover the description states that it is a 'relay-only MTA', this 
also seems to imply that this is not a MTA.

If the definition of the MTA virtual provide is 'any program that
provides /usr/sbin/sendmail and is able to send mail', then 
sure esmtp should Provide MTA, but is it really the best definition
for MTA? I doubt it since it is redundant with providing 
/usr/sbin/sendmail 
Comment 6 Patrice Dumas 2007-11-03 11:34:55 EDT
ssmtp doesn't provides MTA anymore, this is now associated with
full MTA sendmail, exim, postfix (local delivery, mail queue, 
smtp server).

In my opinion it is better to have this meaning for MTA.
You can use /usr/sbin/sendmail for a package providing this
command -- or for a package that can send mail.

Note You need to log in before you can comment on or make changes to this bug.