Bug 235625 - Clicking close button in Firefox crashes X nv driver
Clicking close button in Firefox crashes X nv driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-08 10:30 EDT by Gerry Tool
Modified: 2009-05-19 15:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 15:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server config file requested by maintainer (584 bytes, text/plain)
2007-04-11 09:07 EDT, Gerry Tool
no flags Details
Xorg log file requested by maintainer (42.57 KB, text/plain)
2007-04-11 09:10 EDT, Gerry Tool
no flags Details
Xorg log file after restart with no xorg.conf file (46.11 KB, text/plain)
2007-04-11 10:06 EDT, Gerry Tool
no flags Details
Xorg log file. (46.06 KB, text/plain)
2007-04-11 10:25 EDT, Gerry Tool
no flags Details
Requested log file (42.43 KB, text/plain)
2007-05-30 14:35 EDT, Gerry Tool
no flags Details
Xorg.0.log from the crashed session (91.57 KB, text/plain)
2007-06-23 13:09 EDT, Jan Kratochvil
no flags Details
My `rpm -qa|gzip' (8.54 KB, text/plain)
2007-06-23 13:10 EDT, Jan Kratochvil
no flags Details
Xorg.0.log.old when X crashed (416.37 KB, text/plain)
2008-04-18 17:45 EDT, Dominik Sandjaja
no flags Details
xorg.conf (777 bytes, text/plain)
2008-04-18 17:45 EDT, Dominik Sandjaja
no flags Details

  None (edit)
Description Gerry Tool 2007-04-08 10:30:27 EDT
Description of problem:Clicking on a tab or window close button crashes X and
logs user out.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.0.1-3.fc7

How reproducible: Has happened to me 4 times, no consistency


Steps to Reproduce:
1.surf web in firefox
2.close a tab or the firefox window
3.
  
Actual results:X crashes and logs out user


Expected results:Firefox window should close and session continue.


Additional info: Video card is nVidia G70 [GeForce 7300GT]
Comment 1 Matěj Cepl 2007-04-11 08:47:41 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gerry Tool 2007-04-11 09:07:36 EDT
Created attachment 152266 [details]
X server config file requested by maintainer
Comment 3 Gerry Tool 2007-04-11 09:10:15 EDT
Created attachment 152267 [details]
Xorg log file requested by maintainer

Currently updating system.  Will restart without xorg.conf file afterwards and
send attachments requested.
Comment 4 Gerry Tool 2007-04-11 10:06:03 EDT
Created attachment 152270 [details]
Xorg log file after restart with no xorg.conf file

[root@f7t3 ~]# ls /etc/X11
applnk	prefdm	      sysconfig  X    xinit    xorg.conf.old
fs	serverconfig  twm	 xdm  Xmodmap  Xresources
Comment 5 Gerry Tool 2007-04-11 10:25:48 EDT
Created attachment 152276 [details]
Xorg log file.

This is the file just after X crashed while in Firefox and after I logged back
in just in case that is useful.
Comment 6 Adam Jackson 2007-05-11 17:20:53 EDT
Next time this happens, when X restarts, look at /var/log/Xorg.0.log.old
instead.  It should have a backtrace at the end indicating where the crash
happened.  Please attach that file when you find it.
Comment 7 J French 2007-05-24 07:20:40 EDT
You can have my backtrace, exact same issue:

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x47f5ed]
1: /lib64/libc.so.6 [0x2aaaab17f620]
2:
/usr/lib64/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffer_size+0xc)
[0x2aaab27d5c4c]
3: /usr/lib64/xorg/modules/extensions//libGLcore.so [0x2aaab27d845d]
4: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaabb9173b]
5: /usr/bin/Xorg(compPositionWindow+0x62) [0x4bc5f2]
6: /usr/bin/Xorg(ResizeChildrenWinSize+0x1ce) [0x43a01e]
7: /usr/bin/Xorg(miSlideAndSizeWindow+0x1ab) [0x4ef10b]
8: /usr/bin/Xorg(compResizeWindow+0xad) [0x4bd46d]
9: /usr/bin/Xorg(ConfigureWindow+0xb8d) [0x439b5d]
10: /usr/bin/Xorg(ProcConfigureWindow+0x96) [0x44ab46]
11: /usr/bin/Xorg(Dispatch+0x1db) [0x44b2db]
12: /usr/bin/Xorg(main+0x45d) [0x43404d]
13: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2aaaab16caa4]
14: /usr/bin/Xorg(FontFileCompleteXLFD+0x231) [0x433319]

Fatal server error:
Caught signal 11.  Server aborting
Comment 8 J French 2007-05-24 07:23:00 EDT
btw - I should mention that yes, that's the whole thing.
Comment 9 Matěj Cepl 2007-05-30 12:22:57 EDT
Still, Gerry, could we get yours /var/log/Xorg.0.log, please?
Comment 10 Gerry Tool 2007-05-30 14:35:00 EDT
Created attachment 155726 [details]
Requested log file

This is my current log file.  I have had no recent occurrences of this bug.  I
previously submitted several files on 4/11 which are comments 2, 3, 4, 5 of
this bug report.  If there is something else I can try and submit, let me know.


Current driver:
[root@f7t4 ~]# rpm -q xorg-x11-drv-nv
xorg-x11-drv-nv-2.0.2-2.fc7
Comment 11 Matěj Cepl 2007-05-30 20:24:01 EDT
J French, could you confirm that when upgrading to xorg-x11-drv-nv-2.0.2-2.fc7
the bug could not be reproduced?
Comment 12 J French 2007-05-30 22:04:52 EDT
I cannot, Fedora 7 was so very unstable that I was forced to downgrade back to
FC6. This bug was just one of many that caused this.

Perhaps related: When switching to a VT (ctrl+alt+F1-F6), switching back to X
would crash it in the same manner. These two bugs, combined with an inability to
delete NFS mounted files under Nautilus, effectively made Fedora 7 unacceptable
for use for me.

As stated, when I have more time, I'll look into again, but that's not going to
be for at least a couple days.
Comment 13 Jan Kratochvil 2007-06-23 13:09:59 EDT
Created attachment 157695 [details]
Xorg.0.log from the crashed session

Changed the Component as I am using "vesa" driver and I got the same backtrace:


Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x6d) [0x48b99d]
1: /lib64/libc.so.6 [0x3d6b030620]
2:
/usr/lib64/xorg/modules/extensions//libGLcore.so(xmesa_check_and_update_buffer_size+0xc)
[0x2aaaae53914c]
3: /usr/lib64/xorg/modules/extensions//libGLcore.so [0x2aaaae56941d]
4: /usr/lib64/xorg/modules/extensions//libglx.so [0x2aaaab1b373b]
5: /usr/bin/Xorg(compPositionWindow+0x62) [0x4bf7c2]
6: /usr/bin/Xorg(miSlideAndSizeWindow+0x1cc) [0x4f22fc]
7: /usr/bin/Xorg(compResizeWindow+0xad) [0x4c063d]
8: /usr/bin/Xorg(ConfigureWindow+0xb8d) [0x43a31d]
9: /usr/bin/Xorg(ProcConfigureWindow+0x96) [0x44b306]
10: /usr/bin/Xorg(Dispatch+0x1db) [0x44ba9b]
11: /usr/bin/Xorg(main+0x45d) [0x43480d]
12: /lib64/libc.so.6(__libc_start_main+0xf4) [0x3d6b01daa4]
13: /usr/bin/Xorg(FontFileCompleteXLFD+0x229) [0x433ad9]

Fatal server error:
Caught signal 11.  Server aborting

xorg-x11-server-Xorg-1.3.0.0-9.fc7.x86_64
Comment 14 Jan Kratochvil 2007-06-23 13:10:48 EDT
Created attachment 157696 [details]
My `rpm -qa|gzip'
Comment 15 Jan Kratochvil 2007-06-23 14:26:13 EDT
And it definitely started since installing:
  gtkglext-1.2.0-4.fc6.x86_64
  gnash-0.8.0-1.fc7.x86_64
  gnash-plugin-0.8.0-1.fc7.x86_64

So `yum remove gtkglext' should be the workaround to make F7 usable again.
Comment 16 Jan Kratochvil 2007-07-27 16:40:01 EDT
`yum remove gtkglext' is unfortunately not a complete workaround.

rm /usr/lib64/xorg/modules/extensions/libGLcore.so
still crashes the machine on GL open but ...

---> rm /usr/lib64/xorg/modules/extensions/libglx.so
is the right workaround to prevent unprivileged applications crashing your PC.
Comment 17 Bug Zapper 2008-04-03 20:00:31 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 18 Dominik Sandjaja 2008-04-18 17:44:38 EDT
I have basically the same problem: X crashes when closing programs. Though it
does not happen with firefox but with f-spot, vncviewer, virt-manager.
Seems it always crashes when there is something with graphics involved,
something like overlay or stuff? Will attach xorg.conf, Xorg.0.log.old, anything
else needed?
Comment 19 Dominik Sandjaja 2008-04-18 17:45:37 EDT
Created attachment 302944 [details]
Xorg.0.log.old when X crashed
Comment 20 Dominik Sandjaja 2008-04-18 17:45:55 EDT
Created attachment 302945 [details]
xorg.conf
Comment 21 Dominik Sandjaja 2008-04-19 05:25:37 EDT
Just checked: Also happens with the AccelMethod set to XAA. Will check with the
radeonhd driver in the next step. Though that one is reaaaaallly slow (several
seconds until a window goes into fullscreen, etc.).

BTW, I do NOT use compiz.
Comment 22 Dominik Sandjaja 2008-04-20 06:01:18 EDT
Further investigation:
Tried the hints from comment #16, removed gtkglext-libs (which in turn removed
libvirt-manager and the vnc-viewer) -> f-spot still crashes.
Removing/renaming /usr/lib/xorg/modules/extensions/libglx.so only leads to X
hanging on startup.

Will try with the live-cd of F9 preview release to see if it happens there, too.
Comment 23 Dominik Sandjaja 2008-04-20 07:42:32 EDT
It does not happen when starting the F9 preview i686 live cd, but it happens
when using a "fresh" user on my system. Seems to be something on this system,
though I have no idea what it is and what causes it. Even though it's a beta
system, that kind of crash should be gone a while ago ...
Comment 24 Bug Zapper 2008-05-13 22:45:04 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 25 Mike Pope 2008-06-21 22:00:58 EDT
I can crash xmesa_check_and_update_buffer_size on X startup, on fully updated
F9, but I am using the livna nvidia driver.  Next time I try xorg-x11-drv-nv
(currently broken for me due to #234824) I will see if the problem persists.
Comment 26 Adam Jackson 2009-05-19 15:34:13 EDT
Unable to repro with an nv laptop on F11.  Please reopen if this is still an issue in F11.

Note You need to log in before you can comment on or make changes to this bug.