Bug 235634 - Trackpad on macbook pro (intel) not recognized
Trackpad on macbook pro (intel) not recognized
Status: CLOSED DUPLICATE of bug 208721
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-08 13:17 EDT by Jussi Eloranta
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 11:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X server log (36.17 KB, text/plain)
2007-04-13 13:19 EDT, Jussi Eloranta
no flags Details

  None (edit)
Description Jussi Eloranta 2007-04-08 13:17:07 EDT
Description of problem:
The trackpad on macbook pros (intel) is not recognized. It works in a sense that it is being used
in some sort of compatibility mode, which does not allow for two finger scrolling etc.
I believe that there is some sort of conflict in handling this device as it could be handled by
two different drivers (the compatibility driver) and the (new) appletouch driver. 
There are two parts to this problem, I suppose: 1) get the kernel to use appletouch driver
and 2) provide a proper configuration for the X server. I found some instructions from Ubuntu
forums but they don't work for FC6.

Version-Release number of selected component (if applicable):

FC6

How reproducible:

Install FC6 on a macbook pro and try to get the advanced features of the trackpad to work.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2007-04-10 05:34:23 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jussi Eloranta 2007-04-10 12:06:37 EDT
I will get you this info as soon as I can shutdown my X server. In the mean time
here are instructions for Ubuntu how they got the advanced features of the
trackpad to work (not this is an intel mac):

By default, the generic X mouse driver (mouse) is used. This won’t let you use
cool features like two-finger scrolling, two/three-finger taps (right/triple
click respectively), etc. So, you need to use the synaptics driver, but this
isn’t trivial to do. The appletouch kernel module needs to be loaded before the
usbhid module, otherwise the usbhid mode will act as the driver for the trackpad
(it is USB after all). To do this, I blacklist both drivers, and load them
manually in the order I want. (Please do let me know if there is a better way of
ordering the modules):

/etc/modprobe.d/appletouch: (create)

    blacklist appletouch
    blacklist usbhid

/etc/modules: (append)

    # appletouch should load before usbhid so it claims the trackpad
    appletouch
    usbhid

bigbluevan on the ubuntuforums (specific post) also recommends:

    The only modification I had to make was that, in addition to what is posted
at the above URL, I also needed to add “blacklist tsdev” to
/etc/modprobe.d/appletouch
    I realized that it was loading the ts0 device due to what it was saying in
/proc/bus/input/devices, you need to make sure it only lists mouseX and eventX —
if it has tsX then it means you should blacklist it. 

Then, we have to load the synaptics driver for X (this includes a lot of options
that I’ve found work well for me):

/etc/X11/xorg.conf: (insert after EndSection of the Configured Mouse)

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "CorePointer"
    Option "Device" "/dev/input/mouse1"
    Option "Protocol" "auto-dev"
    Option "LeftEdge" "100"
    Option "RightEdge" "1100"
    Option "TopEdge" "50"
    Option "BottomEdge" "300"
    Option "FingerLow" "20"
    Option "FingerHigh" "30"
    Option "MaxTapTime" "150"
    Option "MaxTapMove" "90"
    Option "MaxDoubleTapTime" "180"
    Option "VertScrollDelta" "25"
    Option "HorizScrollDelta" "30"
    Option "VertTwoFingerScroll" "true"
    Option "HorizTwoFingerScroll" "true"
    Option "FastTaps" "true"
    Option "TapButton2" "3"
    Option "TapButton3" "2"
    Option "MinSpeed" "0.5"
    Option "MaxSpeed" "3.5"
    Option "AccelFactor" "0.35"
    EndSection

Also, we should advise X to load this driver before the Configured Mouse:
/etc/X11/xorg.conf: (Before Input Device "Configured Mouse")

    InputDevice "Synaptics Touchpad"

Great! Now we have the cool capabilities provided by the synaptics driver.
However, I found some issues with the appletouch driver on the MacBook. You can
read more about them here: appletouch (Linux kernel driver for Apple trackpads)
changes. I created a patch that fixes the jumpiness of the mouse pointer and
better detection of multiple fingers (improves two-finger scrolling/multiple
finger taps). Grab the patch: Patch for appletouch driver (patches on top of
Mactel changes)

Comment 3 Jussi Eloranta 2007-04-13 13:19:14 EDT
Created attachment 152561 [details]
X server log

Here is the log - although I think the issue is with kernel detection of the
trackpad (synaptics trackpad).
Comment 4 Matěj Cepl 2007-04-16 10:35:34 EDT
Kristian, do you think the reporter is right and it is really kernel problem?
Comment 5 Ruben Kerkhof 2007-04-17 16:28:41 EDT
Isn't this a duplicate of #208721?
Comment 6 Matěj Cepl 2007-05-22 11:54:31 EDT

*** This bug has been marked as a duplicate of 208721 ***

Note You need to log in before you can comment on or make changes to this bug.