Bug 235639 - GAIM-OTR button missing from GAIM 2 beta 6
GAIM-OTR button missing from GAIM 2 beta 6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gaim-otr (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-08 16:43 EDT by Ben Carner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 23:01:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GAIM chat window without the OTR button (82.31 KB, image/png)
2007-05-04 21:16 EDT, Ben Carner
no flags Details

  None (edit)
Description Ben Carner 2007-04-08 16:43:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10

Description of problem:
Since the upgrade to GAIM 2.0 beta6, the OTR plugin for GAIM does not show the OTR button in chat windows.  This button was the only way to enable/disable OTR, and since it is missing, I cannot disable OTR communications or force restarting them without closing and re-opening GAIM.

Version-Release number of selected component (if applicable):
gaim-2.0.0-0.31.beta6.fc6 gaim-otr-3.0.1-0.3.20060921cvs.fc6

How reproducible:
Always


Steps to Reproduce:
1.With GAIM and GAIM-OTR installed, enable the OTR plugin.
2.Open a chat window
3.The OTR button that normally appears to the left or the right of the user icon (Left of the text entry field) is missing.

Actual Results:
OTR button is missing.

Expected Results:
OTR button should be present, showing the current OTR status and allowing you to perform OTR functions.

Additional info:
The OTR project has released a new OTR plugin for GAIM beta 6.
Comment 1 Paul Wouters 2007-04-08 18:29:14 EDT
It works fine for me using gaim-2.0.0-0.31.beta6.fc6 with
gaim-otr-3.0.1-0.3.20060921cvs.fc6

In fact, one bug i see is that for "merged" users in gaim, I get one otr button
per identity being used.

Can you make sure your system is up to date with gtk/gnome

Does your account already have a key generated? Perhaps the button only appears
after that. That would be after either someone with OTR contacts you, or when
you manually create a new otr key?
Comment 2 Ben Carner 2007-04-09 17:14:28 EDT
All updates have been applied.  I'm using yum-updatesd on one machine and a
nightly "yum update" on the other.  I'm up to date as of today (4/9/07).  I'm
using the same versions of as you are, but I also have the
gaim-libnotify-0.12-3.fc6 package.  The plugins I have activated are:

ExtPlacement (2.0.0-0.32.beta6.fc6)
History (2.0.0-0.31.beta6.fc6)
Libnotify Popups (0.12)
Message Notification (2.0.0-0.31.beta6.fc6)
Off-the-Record Messagine (3.0.0) (RPM version:
gaim-otr-3.0.1-0.3.20060921cvs.fc6 from Extras)
Text Placement (2.0.0-0.31.beta6.fc6)

I have keys created for all my IM accounts, and keys received (Some verified,
some not) from various contacts.

This worked fine until Beta6 was released.  I had the OTR button to the left (or
right, sometimes it switched) of the user icon in the chat windows.  I still
have "OTR Settings" in the popup menus in the Buddy List and under the
"Conversation -> More" menu in the chat window (I use tabbed chat).  I haven't
changed anything since before Beta6 was released.

I don't know how to "merge" users in GAIM.
Comment 3 Paul Wouters 2007-04-11 01:33:53 EDT
I enabled all those plugins. I had to install gaim-libnotify seperate. I
restarted gaim. And it just works like a charm. I do not know why you are having
this problem. I don't know how to reproduce it.
Comment 4 Mike Perry 2007-04-11 02:23:45 EDT
I would like to add this happened to me Buddy State Notification, History, I'dle
Mak'er, and Message Notification enabled. Additionally, OTR forgot my private
key,  which seems to have had the property of expiring the known state of all my
buddies.

I recompiled OTR from source and the icon problem went away (though my key is
still missing... hurray for backups). Though interestingly I had to change the
header gtkstock.h to gaimstock.h. Perhaps some interfaces in gaim also changed
with the header name change?
Comment 5 Paul Wouters 2007-04-11 02:48:22 EDT
Those fixes are in the cvs version.

The reason your keys went missing after an upgrade is because gaim renamed the
AIM/ICQ protocol internally to two different oscar protocols. So gaim-otr didn't
find your key. You can rename your old keys to the right filename to fix that.

I am still confused why i dont see these problems. Tomorrow I'll remove all of
gaim and gaim otr and yum install to see what happens.
Comment 6 Ben Carner 2007-04-12 00:24:26 EDT
I personally know of three other people who are having this problem.  All of us
lost the button at the same time.  Everything else about OTR works, but that
button is gone and we all have to restart GAIM if we can't otherwise get an OTR
session restarted.  All of them run updates on a regular basis and are all
running the version of GAIM and OTR I mentioned in the original submission.
Comment 7 Ben Carner 2007-04-12 00:25:24 EDT
I should also point out that we've all been using OTR since GAIM 1.5 without
having to reconfigure it at all.  All we had to do was generate a key per
protocol and we haven't touched it since then.
Comment 8 Paul Wouters 2007-04-12 01:02:34 EDT
I quit gaim, and ran "yum remove libotr gaim-otr" on my FC6 machine. I then ran
"yum install gaim-otr". I then started gaim, and had OTR buttons.
Comment 9 Paul Wouters 2007-04-12 01:34:34 EDT
I created a new account. logged as the new user. started gaim. added my MSN
account, enabled OTR plugin, selected config tab, generated key, and clicked on
a random buddy, and i got a window with the OTR button.

I'm sorry, I cannot reproduce your problem :(
Comment 10 Ben Carner 2007-04-14 23:28:51 EDT
I tried the same thing. I removed and re-installed gaim-otr, and even moved my
.gaim directory out of the way, then started GAIM and re-created my accounts,
even re-generating new keys, but still, after all that, I still did not get the
OTR button in the chat windows.

Is there any debugging options I can turn on or anything else that I can do to
try and isolate what the problem could be?
Comment 11 Paul Wouters 2007-04-15 00:08:35 EDT
I don't know. Try running gaim with the debug (-d) option and see if that helps?

I just logged onto a FC6 server that didn't have Xwindows. Installed gaim-otr,
which brought in all the stuff, then ran gaim remotely (ssh -X -A remotehost
gaim). It popped up, I logged in one of my accounts. enabled otr plugin,
selected configure plugin, generated key, and then closed the config windows.
double clicked on a random buddy and it showed the OTR button.

Whatever it is, it is specific to your system. I can't reproduce it. Look in
installed third party modules that arent part of fedora?

I'm sorry. I'm really trying to reproduce your and your friends' problem, but I
cannot. Try and see what you and your friends have in common that's not-default?
Comment 12 Vic Ricker 2007-04-25 10:17:00 EDT
I also have this problem.  I tried re-installing the otr rpms, as suggested by
Paul Wouters, but that didn't help.

I tried disabling all other plugins but that didn't help either.
Comment 13 Ben Brown 2007-05-04 18:46:33 EDT
I'd like to chime in here, since I'm experiencing the same issues on my machine.

Just to make sure it wasn't a 3rd-party repo I was using (I didn't really
suspect it was, because the Gaim RPMs being installed are all from Extras), I
spent some time today reinstalling FC6 on a spare machine.

I did a default install (without customizing the packages or adding other
repos). As soon as it booted, I did a 'yum -y update'. Once that was completed,
I rebooted. Then I ran 'yum -y install gaim-otr' which installed the following
packages:

gaim-otr-3.0.1-0.3.20060912cvs.fc6
libotr-3.0.0-2.fc6

Then I fired up Gaim, logged in with my AIM account, enabled the OTR plugin, and
generated keys.

STILL no OTR icon in the chat window!

So, I must respectfully disagree with your comment above that it is specific to
our systems -- I mean, I've got the problem on the laptop I use at work, my home
machine, and now this random machine I used just for a test.
Comment 14 Ben Carner 2007-05-04 21:16:43 EDT
Created attachment 154186 [details]
GAIM chat window without the OTR button

Attached is a GAIM chat window with an OTR-encrypted chat session with a
friend, but without the OTR button, which is the basis for this whole bug
report.
Comment 15 Ben Carner 2007-05-04 21:19:34 EDT
I uploaded a screenshot of my GAIM chat window open with an OTR-encrypted chat
going.  As can be seen, the OTR button is missing.
Comment 16 Paul Wouters 2007-05-05 00:17:03 EDT
It is not that I do not believe you. It is just that I cannot reproduce it. And
I have no idea why this is happening.

Also, gaim-otr needs to be fixed for gaim->pidgin. Let's see if that will also
resolve your issue
Comment 17 Ben Carner 2007-06-04 12:10:06 EDT
This seems to have been corrected by the pidgin.i386 2.0.1-1.fc6 and
gaim-otr.i386 3.0.1-0.6.20060712cvs.fc6 (Which should be renamed) updates as of
June 04.  My button is back!
Comment 18 Paul Wouters 2007-08-06 22:58:01 EDT
pidgin-otr has just been approved as a new package, and replaces gaim-otr. It
also comes with some new features and requires libotr-3.1.0.

I just looked at FC6 and I could not find pidgin for it though. So I also did
not add a branche request for FC6. I'll fix that now and upgrade them.

Note You need to log in before you can comment on or make changes to this bug.