Bug 235661 - Changing laguages causes aplications to use old language desktop folder instead of the new translated one.
Changing laguages causes aplications to use old language desktop folder inste...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 235662 (view as bug list)
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-09 07:48 EDT by FranciscoMendonça
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 16:06:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FranciscoMendonça 2007-04-09 07:48:34 EDT
Description of problem:
When changing system languages, several folders on the /home/user are created
instead of renamed to match the new language. Among these folders is the Desktop.
For starters the folders should be renamed to keep files on their respective
equivalents, but the biggest problem is with the Desktop folder. The Desktop
folder displayed is the new translated one, but for gnome applications (nautilus
not included) the name displayed is the translated but the folder is the old
Desktop folder.

Version-Release number of selected component (if applicable):
FC7 Test 3 with Gnome.

How reproducible:

Just change your language in System/Administration/Language, in this case we
will be using Portuguese. Logout and login again and you'll be prompted to
create the new folders. Chooose yess
Steps to Reproduce:
1. Create a file on the "Desktop" folder named "old". And a new on your recently
created "Ambiente de Trabalho" folder (Portuguese equivalent for desktop) create
a file named "new".
2. Everything works ok if you browse with nautilus, although the files that were
on the desktop prior to the new language SHOULD be copied to the new "Ambiente
de Trabalho" folder.
3. Open any application, We will be using gimp. Choose open file and on locals
(the side bar) Choose "Ambiente de trabalho". As you can see there by the "old"
file displayed we are looking at the old Desktop folder (the one prior to the
translation) instead of the new one.
  
Actual results:
1- Files on old language folders aren't moved to the new ones and the old
folders aren't deleted.
2- Most applications still use the old folders instead of the new translated ones.

Expected results:
1- Old folders simply renamed to their new language equivalent.
2-Applications should use the new language ones instead of pointing to the old ones.

Additional info:
Comment 1 Matthias Clasen 2007-04-09 10:57:21 EDT
Alex, is this a problem of xdg-user-dirs doing the update too late, after
nautilus has already been started ?
Comment 2 Ray Strode [halfline] 2007-04-09 10:59:14 EDT
*** Bug 235662 has been marked as a duplicate of this bug. ***
Comment 3 FranciscoMendonça 2007-04-09 12:28:53 EDT
Some more details that occurred to me after posting the bug:
- Used the Gnome Live cd to install. (No prompted system language on Anaconda).
- The /home partition wasn't formated. I kept the same home from Fc6.
Comment 4 Alexander Larsson 2007-04-10 09:22:39 EDT
Isn't the problem that the fileselector shows ~/Desktop instead of using the XDG
user dirs? I mean, the reporter says it works in nautilus.
Comment 5 Matthias Clasen 2007-04-10 10:16:52 EDT
I must have missed that this is about the file chooser...
Comment 6 Matthias Clasen 2007-04-10 16:06:23 EDT
Should be fixed in the gtk2 and libgnomeui releases I built today.

Note You need to log in before you can comment on or make changes to this bug.